Jump to content
TNG Community
Philip Roy

Template 18 - Removing scrollbars in the notes section

Recommended Posts

Philip Roy

I'm in the process of setting up a private site for family members (this explains the blurred text in the image attached) based on information that mum and dad entered into Reunion over a number of years, using TNG and template 18.

Mum and dad used the "Notes" field in Reunion as a place to write biographies of some people...not horrendously long text, but also not short notes either.

For that reason, I have set the Notes section in TNG to display higher up on individual pages...but instead of displaying the full text of the field, it's putting scroll bars into the text area, which makes reading a bit awkward (the image I'll upload has an arrow pointing to the scrollbar).

Is there a simple way to turn off the scrollbars within the notes area? Either by an admin setting or a simple hack to the template?

On a side note...if there is a better place in an individual page/record to place a biography (and how you would go about that)...then I'm open to making adjustments...although that will be a lot of work for me, in both in TNG and Reunion.

Cheers,

Phil 

scroll.png

Share this post


Link to post
Share on other sites
Ken Roy

In Admin > Setup > General Settings in the Miscellaneous section, there is an option Scroll citations:  you might try setting it to No and see if that also eliminates the scroll bar from Notes.

Share this post


Link to post
Share on other sites
Philip Roy

It's already set to No, thanks...so it doesn't impact the Notes section...just Citations apparently.

Phil

Share this post


Link to post
Share on other sites
Philip Roy

So I think I found what is causing the issue...it's a CSS value for the notes area, found  at /css/genstyle.css

.notearea {
    max-height:200px;
    overflow:auto;
}

According to this page - https://tng.lythgoes.net/wiki/index.php?title=Understanding_TNG_css_styles

I can use.../templates/template18/css/mytngstyle.css

...to override it with....

.notearea {
    max-height:none;
}

Except at the moment, that is having no impact whatsoever. I am hoping it is a caching issue with Siteground. I have experienced caching problems a couple of times already with changes I make...so I will leave it 24 hours and see if the scrollbars disappear.

Phil

Update 5 minutes later - Caches! It came right just after I posted this message. Solved :-)

Edited by Philip Roy
Solved

Share this post


Link to post
Share on other sites
Ken Roy

Phil,

Glad you found the answer.  

You might want to update the TNG Wiki article to add the notearea class and indicate that it controls how notes are displayed.  Yes, cache is often and issue with css even when you try to do a forced reload.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×