Jump to content
TNG Community
Donna T

TNG is not communicating with your database

Recommended Posts

Donna T

" Error: TNG is not communicating with your database. Please check your database settings and try again. Settings can be found under Admin/Setup/General Settings/Database, or at the top of your config.php file. "   is the message when attempting to load my page

i am very ignorant of all of this....do not know anything about what i would be looking for or how to correct this. i would appreciate any suggestions or if there is someone who can fix for me for a fee?

feel free to contact me at salem_03079@yahoo.com as I do not know i will receive any messages that are thru my website.  thanks so much, dee

 

Share this post


Link to post
Share on other sites
Donna T

thank you....i appreciate your pointing me in the correct direction.

dee

Share this post


Link to post
Share on other sites
vezet

I have also a problem with the communication with data-base.   In the  https://tng.lythgoes.net/wiki/index.php/TNG_not_communicating_with_database , there
is no solution for me. All settings in config.php and in the Setup are the same. It happens only in the popup of a photo or document. 
The text of the photo or document are normally shown in the popup, now it is: " Error: TNG is not communicating with your database. Please check your database settings and try again. Settings can be found under Admin/Setup/General Settings/Database, or at the top of your config.php file. " 

On Mac system no problem, it happen in Windows 7 and in Windows 10.  TNG version used is 12.2, webbrowser: firefox

 Regards, 
Vezet

 

Share this post


Link to post
Share on other sites
Donna T

i am sorry to hear of your difficulty. maybe someone on the forum can assist.

i do not know what happened on my end......it worked the next time i opened my browser - the page loaded no problem....i do not understand why. i am just thankful it did.

best wishes
donna

Share this post


Link to post
Share on other sites
Ken Roy
16 hours ago, vezet said:

It happens only in the popup of a photo or document. 
The text of the photo or document are normally shown in the popup, now it is: " Error: TNG is not communicating with your database. Please check your database settings and try again.

Firefox often has popup blocking enabled.  Are you allowing the Popup for your TNG Wiki site?

Do you have mods that display the photo or document?

Share this post


Link to post
Share on other sites
vezet
6 hours ago, Ken Roy said:

Firefox often has popup blocking enabled.  Are you allowing the Popup for your TNG Wiki site?

Do you have mods that display the photo or document?

Popup are free to open,  the Map MODS is empty, just only the index file.

I made a new tree, add 1 person. For that person I added a photo.

As soon I mouse over the thumbnail the popup photo gives the photo also teh mentioned error instead of the
text belonging to the photo.

It happened only in Windows 7 and 10, I'm using MAMP for local host.

Vezet

 

hubertus-windows-1.jpg

hubertus-windows-2.jpg

Hubertus-MAC.jpg

Share this post


Link to post
Share on other sites
Ken Roy

Sorry, I do not know anything about MacIntosh.   Since you are trying to access MAMP from a Windows machine, it could be a MAMP setup issue some place that prevents the database access or a MacIntosh local network setting needs to be changed

I have seen the TNG Cannot communicate error on WampServer when one of the Database Management Services (DBMS) is not started or when Apache is not started.  More recently, I have seen it when I used a full install of WampServer 3.2 on a new Windows 10 laptop where the DBMS default server was changed from MySQL to MariaDB which then required that a port be specified in the General Settings for the Database section

Best regards in solving your problem.

 

Share this post


Link to post
Share on other sites
jrueger

I had a similar message when I tried to use PHP 7.4 on my webserver - reverting back to PHP 7.3 resolved the issue.

Share this post


Link to post
Share on other sites
Ken Roy
15 hours ago, jrueger said:

I had a similar message when I tried to use PHP 7.4 on my webserver - reverting back to PHP 7.3 resolved the issue.

Was this problem reported to Darrin?

Share this post


Link to post
Share on other sites
jrueger

No I didn't report it ... I had just noticed that my hosting provider had PHP 7.4 available and tried it out ... seemed to kill TNG (it wouldn't load at all) and so I rolled back.  I don't have a burning need for PHP 7.4 so didn't really try to troubleshoot or resolve the issue.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×