Jump to content
TNG Community
Sign in to follow this  
Carl Rhodes

Installed from TNG 11.2 to 12, having issues with templates

Recommended Posts

Carl Rhodes

I've gotten the following error message after installing TNG 12 from 11.2. 

Quote

An error has occurred in the TNG software. This could be due to a setup issue, an incomplete upgrade or a program bug. If you are the site owner, you may contact TNG support for help with this problem. Please copy the query below and paste it into your message.

Query: SELECT * FROM ORDER BY template, ordernum

You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'ORDER BY template, ordernum' at line 1

Now unable to change templates.

 

Share this post


Link to post
Share on other sites
bhemph

It appears that you missed the database update step, and maybe a couple of others that relate to template changes.  If you go back through the readme and make sure to complete the steps, it should fix your issue.

Share this post


Link to post
Share on other sites
ChrisB

I'm trying to work through a similar issue, upgrading from 12.02 to 12.2.

The upgrade_db_12x-12x.php looks like it should be putting the name of the template table into the query...but the query in the error message doesn't contain the table name.... as if the $templates_table variable is not set.... 

echo "Entering new template settings into the database...";
$query = "INSERT IGNORE INTO $templates_table (template,ordernum,keyname,language,value) VALUES ";


Query: INSERT IGNORE INTO (template,ordernum,keyname,language,value) VALUES ("200","1","maintitle","","History of the Surname Family"),

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '(template,ordernum,keyname,language,value) VALUES ("200","1","maintitle","","His' at line 1

 

Looking for where $templates_table is set....

Share this post


Link to post
Share on other sites
ChrisB

My issue was that I had accidentally overwritten config.php with an older version.  The upgrade from 11x to 12x writes some new variables into there, and one of them is $templates_table.  

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×