Jump to content
TNG Community
LJLachance

Image Captcha - Images not copying

Recommended Posts

LJLachance

Using the latest build of TNG (12.2) and attempting to use Rick Bisbee's Image Captcha.  When installing the mod, I get the following:

line 21: %target:TNG_captcha.php% verified

line 38: %location:% #1 not installed

line 50: %parameter:$max_images:8
line 54: %parameter:$capsize:72
line 60: %copyfile: cap_image.php  not copied
Source: mods/image_captcha_v12.0.0.6/cap_image.php
line 62: %target:@cap_image.php% file missing (optional) will ignore
line 102: %target:customconfig.php% verified

line 103: %location:% #1 not installed

The image captcha config file is in the mods folder along with the file folder, image_captcha_v12.0.0.6 as it was extracted.  

The images are not available in options although it does show the names of them

Quote

 

Image set to use for captcha
If you are using a custom path to your mods folder, the images will not display below. Please consult the img folder inside the Image Capture support folder.

For custom images select '0' and add image paths below

1. moonstruck moonstruck etc.

 

 

Any ideas what I might be doing wrong here

Share this post


Link to post
Share on other sites
kazooter

Your screen shot is exactly the way the mod should appear in the mod listing before installation. 

In the image_captcha support folder there should be a folder - 'img' containing the images.  Do you have that folder?

If not download the mod again.

If the images are present in the img folder, have you renamed your mods folder to something else.  If you have, and if $modspath in your config.php file points to it, I will need to update the mod to use it.  Let me know and I will fix it today.

Share this post


Link to post
Share on other sites
LJLachance

The screen shot was after I "clicked" install - so it was post installation. The "image_captcha support"  not sure ..  Here's what I have after unzipping - 

Folder: Image_captcha_v12.0.0.6

Inside this folder I have is second folder: Image_captcha_v12.0.0.6 AND the Image_captcha_v12.0.0.6.cfg (config file)

Inside the second folder:

Folder: Img

Folder: Languages

File: cap.inc.php

File: cap_image.php

The "img" folder DOES, in fact, contain the images.

I have not renamed the mods folder and, in fact I have two other mods in that folder that are work fine one of them recently installed.

In the config.php file,  I have $modspath = "mods";

As an aside, ALL of the TNG is running is a separate folder in my public heirarchy named "genealogy" - but that has never made any difference in the past??? mods_folder.jpg 

Mods folder image above.

Guess I don't understand what the line from the mod install means? "line 60: %copyfile: cap_image.php  not copied"

One other note - I recently updated to 12.2 and I saw in "mod manager" the tab - "recommended updates".  I never did this as I'm not sure it's required.  Is it possible that this might have something to do with it?

 

Thanks for your quick reply.

 

Larry

mods_foler.jpg

Share this post


Link to post
Share on other sites
theKiwi
3 minutes ago, LJLachance said:

Folder: Image_captcha_v12.0.0.6

 Inside this folder I have is second folder: Image_captcha_v12.0.0.6 AND the Image_captcha_v12.0.0.6.cfg (config file)

You need to take the inner folder image_captcha_v12.0.0.6 and the .cfg file out of the folder Image_captcha_v12.0.0.6 and have them in the "mods" folder

Roger

Share this post


Link to post
Share on other sites
LJLachance

So, place the files in the mods folder as pictured here:

mods_folder_rev1.jpg

and I go to Mod Manager and I get this:

mod_manager.jpg

Now I can't install it all...

When I extracted the files from the zip download - here is what comes out

extracted_files.jpg

If I put these extracted files in the mods folder per the instructions in the wiki article, then, when I go to mod manager in admin,  I have the option to install but when I do install I get what I had the first time around in mod manager

line 21: %target:TNG_captcha.php% verified

line 38: %location:% #1 not installed

line 50: %parameter:$max_images:8
line 54: %parameter:$capsize:72
line 60: %copyfile: cap_image.php  not copied
Source: mods/image_captcha_v12.0.0.6/cap_image.php
line 62: %target:@cap_image.php% file missing (optional) will ignore
line 102: %target:customconfig.php% verified

line 103: %location:% #1 not installed

 So where am I going wrong - can someone show me HOW the files are ordered in the mods folder, if different from what I did the first time around?

 

Share this post


Link to post
Share on other sites
kazooter

Looks like you were doing it right.  The image_captcha_v12.0.0.6 folder goes into the mods folder.  The image_captcha_v12.0.0.6.cfg goes into the mods folder.  When you list the mods in Mod Manager you should see it as Okay to install.  Click on the Install button and it should list with details below.

SS1.jpg

It just looks like the mod did not install when you pressed the install button.  Your first message implied you could access the Edit Options page -- but I don't see how you could if the mod were not installed.  Here is what the Edit Options page should look like after installation.  Is this what you saw?

ss2.jpg

Share this post


Link to post
Share on other sites
LJLachance

So this time, I downloaded the zip file again, extracted and placed the files exactly as before.  This time I got a different message in the details. This time it shows cap_image.php was copied -

details.jpg

BUT ... in the edit options - this is what I get...which is the same as before

edit_options.jpg

 

I'll take whatever suggestions you might have...I really like this option

Share this post


Link to post
Share on other sites
LJLachance

I have continued to search for reasons why my images are not showing in Mod Manager options.  The only mod I had that was pre-v12 was FGW tabs and I've uninstalled and reinstalled the latest version which works as expected AND did not correct the image display issue.

What I have noticed, however, is that in MY Mod Manager, the Wiki Image also DOES NOT appear?  Here is a comparison of the visualization of both my own mod manager and the one from the Wiki page. 

mod_manager_difference.jpg

 

Could this be indicative of an issue with my coding someplace?  Or is it possible that my mod manager is somehow corrupt?  I've been doing upgrades since before TNG version 9 - maybe I'm missing something?  I do have a custom config file but it's only purpose is to place images for the FGW mod.

Something is wrong and if anybody has suggestions, please let me know. I really don't want to start from scratch with TNG but, if that is the only alternative, so be it...  Thanks for the help.

Larry

 

Share this post


Link to post
Share on other sites
Ken Roy

Larry,

Can the Mod Manager write to your TNG img folder?

Share this post


Link to post
Share on other sites
LJLachance

Well sir - I don't know the answer to that.  Is there an easy way to find out?  

Share this post


Link to post
Share on other sites
Ken Roy

You could look at the folder and file permissions, with the cPanel File Manager or FileZilla FTP client.

Another possibility is that your TNG Genealogy URL is not defined correctly, but then I would expect you to have problems with other TNG Admin screens.

Edited - if you use the brower Inspect Element for where the image should display, what does it show.  Or if you right click and tried to View image

Share this post


Link to post
Share on other sites
LJLachance

File permissions are set 0755. I would assume that the TNG Genealogy URL IS defined correctly as this particular mod is the only thing I'm having issues with.

Thanks for the "kick" to check the browser inspect element - for what it's worth, where one of the images should be reads as follows:

<img src="cap_image.php?n=74088" width="72" height="72" alt="#7">

If I look at the table that is inserted - this is what I see:

dev_inspect.jpg

Doesn't this imply that no images are being added?

Thanks for your help on this as well. 

 

Share this post


Link to post
Share on other sites
Ken Roy
4 hours ago, LJLachance said:

What I have noticed, however, is that in MY Mod Manager, the Wiki Image also DOES NOT appear?

Larry,

Based on one of your first posts, you are also not displaying the Mo Manager wiki icon, so something is not correct someplace.  The image being empty implies that it cannot find the images.  The TNG Wiki icon should be in classes/wiki16.png

Best I can tell the Image Captcha images are in mods/image_captcha_v12.0.0.6/img/cap...

Note that the Edit option screen indicates If you are using a custom path to your mods folder, the images will not display below.

Since I rename my mods folder on my WampServer environment, the images do not show, but then I the option that allows me to use my own images

Share this post


Link to post
Share on other sites
LJLachance

I'm using the default path in the mods folder.  And, yes, something isn't right but now the big question of the day is, how do I find out and fix it.  Literally everything else is working fine as far as I can tell. In fact, the TNG Wiki icon IS in classes/wiki16.png as you have indicated. And, the Image Captcha images are, in fact, located in mods/image_captcha_v12.0.0.6/img/cap...(the default). 

It seems that something is not right with Mod Manager.  Is it possible to replace it without losing everything?  Any other suggestions?  Is there a config file for the mod manager that might have something wrong or corrupt?  

Share this post


Link to post
Share on other sites
Ken Roy

Larry,

Do NOT mess with the Mod Manager.  We need to get to the bottom of this problem and not complicate it by replacing components

If you want me to look at it use my web site Contact Us form and send me TNG Admin access, and FTP access.

Share this post


Link to post
Share on other sites
Ken Roy

Larry,

Do you have any sort of image security on your site?  Who is providing your SSL certificate?  FileZilla  indicates it does not recognize the certificate (that might be normal)

I replaced the wiki icon and it now displays.  When I tried to display it initially it indicates that it cannot be displayed because it contains errors.  I was able to get one of the images for the Image Captcha to display after  i replaced all the images, but when I try to display a different image, I can a similar error message. 

I cannot right click to copy the error message text and cannot even view your page source, so you must have implemented something in your .htaccess file that is messing things up

Share this post


Link to post
Share on other sites
Ken Roy

I ended up doing a forced reload on each image individually after uploading the images in order to get rid of the message that says it cannot display the image because it contains errors.

edit.  The images are now there so you should be able to choose your images for the Image Captcha.  I am not sure I understand why the image generated an error message.

Share this post


Link to post
Share on other sites
LJLachance

There is nothing that I use that provides image security. FileZilla doesn't recognize the SSL certificate but, I believe that is normal as well.  I'm not at home at the moment so I can't look at my files to find out who is providing the certificate.  Short of blocking specific URL's (particularly from areas in Europe) the htaccess file should not contain anything unusual.  

This issue seems to only appear in conjunction with the ModManager - there are hundreds of images throughout my site, both the main site and the TNG portion.  I'm using the Tabs Mod without issue and it finds the images I use there without issue.  That is part of the Extensions folder and not the Mods folder, maybe that makes a difference?  

Share this post


Link to post
Share on other sites
kazooter

It definitely looks like an image file path issue.  In that Edit Options display, can you right click on one of the image place holders and select Inspect Element.  You should see the following:

<img src="mods/image_captcha_v12.0.0.6/img/cap001f.png" title="moonstruck" alt="moonstruck">

If you do, then the path may be wrong.  Are you using a Wordpress site?  Filepaths can be a challenge with WP.

Tell me what you see.

Share this post


Link to post
Share on other sites
LJLachance

So this issue is officially resolved - actually through the most valiant efforts of Ken working with me throughout the day, he somehow managed to get the files working again AND, most relevant, his suspicion that something was happening in the actual transfer / upload of the files to the host server was correct. 

In the last 10 minutes I proved it.  I am using FileZilla Pro for FTP.  There are multiple settings one can use for Encryption, selection of server type, Transfer Settings (Active, Passive, or Auto) and even Charset.  I'm not good enough to know specifics on what should or should not be set.

However, I went to try to add my own images, added a folder in the v12...folder called "capimg" and placed my images there.  When I pointed captcha to these images, I was back to my first issue - nothing showed.  So next I renamed two of the images in the existing img folder and used the same names as set 1 for my images.  Once again, no go.  Then I noticed that my uploaded images were 100kb smaller than the actual images I uploaded.  

Next step, deleted the images from the server, went back to my antique version of WSFTP Pro (only uploads in passive mode and I don't think encrypted) but, the images uploaded perfectly and sized correctly and they work.  

Now if I can add a folder to the v12...folder for my own images and figure out the correct path to get them, I'll probably do that.  For now however, all is good.

I really appreciate everyone's help tracking this down, it's been a process that's for sure. But at the end of the day, everyone's mod/code did work and FileZilla was the culprit.

Thanks again....  

Share this post


Link to post
Share on other sites
kazooter

Glad you and Ken got it working.  I suggest with FileZilla you transfer all files in binary mode if you are not already doing so. Anything else can cause problems.

Share this post


Link to post
Share on other sites
LJLachance
9 hours ago, kazooter said:

Glad you and Ken got it working.  I suggest with FileZilla you transfer all files in binary mode if you are not already doing so. Anything else can cause problems.

Thanks for the suggestion.

Just in case anybody needs it, to set this, open FileZilla; go to the "Transfer" tab at the top, got to "Transfer Type", select "Binary"... and yes this did solve the issue with FileZilla.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×