Jump to content
TNG Community
Figi4

Contact form with Gmail settings returning PHP error

Recommended Posts

Figi4

When I realized that I was not receiving the email from Contact form etc I went looking into the wiki and the forum.  Im having trouble finding what I do not have set correctly.  Does anyone else use gmail successfully? 

I've filled out the smtp information (see attached) and get this error message below.  

Can someone help me fix this please?  Thank you!  ( Im running TNG 12.1 and template 13.  Its new and only has the OpenStreetMap mod.)

 

Quote

Fatal error: Uncaught phpmailerException: SMTP Error: Could not authenticate. in /srv/disk2/3123167/www/ourfamilyforest.com/genealogy/class.phpmailer.php:1692 Stack trace: #0 /srv/disk2/3123167/www/ourfamilyforest.com/genealogy/class.phpmailer.php(1540): PHPMailer->smtpConnect(Array) #1 /srv/disk2/3123167/www/ourfamilyforest.com/genealogy/class.phpmailer.php(1335): PHPMailer->smtpSend('Date: Thu, 22 A...', 'Comments (Our F...') #2 /srv/disk2/3123167/www/ourfamilyforest.com/genealogy/class.phpmailer.php(1213): PHPMailer->postSend() #3 /srv/disk2/3123167/www/ourfamilyforest.com/genealogy/tngmaillib.php(53): PHPMailer->send() #4 /srv/disk2/3123167/www/ourfamilyforest.com/genealogy/tngsendmail.php(138): tng_sendmail('name', 'myemail@gma...', 'Our Family Fore...', 'myemail@gma...', 'Comments (Our F...', 'Comments (Our F...', 'myemail@gma...', 'myemail@gma...') #5 {main} thrown in /srv/disk2/3123167/www/ourfamilyforest.com/genealogy/class.phpmailer.php on line 1692

 

screenshot.JPG

Share this post


Link to post
Share on other sites
Ken Roy

You probably should report this error to Darrin.

Share this post


Link to post
Share on other sites
jrueger

Have you tried using Port number: 465 and Encryption: ssl ?  It looks like your error is only related to using tls ( line 1692 of class.phpmailer.php).

Share this post


Link to post
Share on other sites
slowjim

I am getting the exact same 5 errors. The settings for outbound I used are exactly the same I use with my email clients.

smtp.jpg

Share this post


Link to post
Share on other sites
jrueger

I have found that the Encryption setting needs to be in lowercase - i.e ssl rather than SSL ...

Share this post


Link to post
Share on other sites
slowjim

jrueger - you were right! putting 'ssl' in lower case solved the problem. It now works. Thanks!

Share this post


Link to post
Share on other sites
Figi4

I contacted Darrin and he suggested for me to not use Gmail as there were too many problems.  Once I switched to my domain email it worked perfectly. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×