Jump to content
TNG Community
SharonM

Google API key, TNG9

Recommended Posts

SharonM

I'm trying to get the maps feature working in TNG9 and have a google API key, which I got for my desktop software (Family Historian). My first question is - do I need to buy another API Key for TNG?

I'm following the instructions at https://tng.lythgoes.net/wiki/index.php?title=Google_Maps_-_Getting_Started , but when I get to the TNG Map Settings the instructions and screen shot are different to those in my version, most notably, there is nowhere to enter the Google APi Key reference! See below.

I assume the Wiki is updated for the latest version on TNG, buy I can't find anything  specifically for maps in version 9.

Can anyone help please?

Thank you, Sharon 

image.png

 

Share this post


Link to post
Share on other sites
Ken Roy

Sharon,

The Google Maps v2 API key support is not available for TNG v9.  Support for the V2 API key was added in TNG v11.0.2 and a patch provided to TNG 11.0.1 in July 2016 when Google started requiring a key for their Maps API that June and the V3 API is not yet supported in TNG

Share this post


Link to post
Share on other sites
SharonM

Thank you. The maps in option in v9 is presumably left over from before Google required the key then.

 Thank you for the clarification. 

Sharon

Share this post


Link to post
Share on other sites
Brett

Sharon

12 hours ago, Ken Roy said:

The Google Maps v2 API key support is not available for TNG v9.

As Ken said, Google Maps key support is not available for TNG v9.

For TNG 10.1.3 and above, there is a Mod which allows the Open Street Map (OSM) to be displayed.

There has been discussion on the TNG Forum on Replacing Google Maps with OSM .

While I am not sure it will work on TNG 9.0.4, I do have the Open Street Map mod, with some manual installation, running on TNG 9.2.2.

If you have no reason to upgrade your TNG, other than to display the maps, please let me know if you would like some help in testing on TNG 9.0.4.

12 hours ago, SharonM said:

The maps in option in v9

If you do not want to display the 'For Development Purposes" messages on the Google map, you choose the Enable Maps option as No.

 

Share this post


Link to post
Share on other sites
SharonM

Thank you for the offer Brett. I am thinking about upgrading anyway, but it will depend on how complicated it is to upgrade. I'm looking for some information about the process on here and on the wiki, and I'll get back to you if I decide not to go ahead. 

Thanks again,

Sharon

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×