Jump to content
TNG Community
Mark Kosinski

Census Plus International Issue When Updating To V12.0.0.10

Recommended Posts

Mark Kosinski

After successfully updating CP International and the CP International Language Mods and updating the CPI Label Table and the CPI Veteran Table I get the following error on any page containing census data:

Quote

An error has occurred in the TNG software. This could be due to a setup issue, an incomplete upgrade or a program bug. If you are the site owner, you may contact TNG support for help with this problem. Please copy the query below and paste it into your message.

Query: SELECT cp_data.cpbaseID AS th, surname, givenname, relation, household, cplineno, lineno, censusYear, street, sex, race, age, birthdate, birthplace, fatherBthplace, motherBthplace, household,immigration, occupation, veteran, status, street, location, personID, nbrSlaves, nbrSlaveHouses, comments, cpdataID, yearsMarried, chborn, chliving, nationality, religion, tribal FROM cp_data LEFT JOIN cp_link ON cp_data.cpdataID = cp_link.cpdataID WHERE cp_data.censusYear = "1920" AND household LIKE "406" AND (cp_data.transcriptID LIKE "dbid=6061&iid=4384791_00%") AND cp_data.location = "Erie, Erie, Pennsylvania, USA" ORDER BY cp_data.transcriptID ASC, lineno+0 ASC

Column 'censusYear' in field list is ambiguous

I checked the database and in the cp_data table the column censusYear does in fact exist and is populated with data as well as in the cp_link table. The current PHP version I am using is 7.2.20 on SiteGround.  I rolled back to V12.0.0.9 of the Mod and everything is back to normal without the error.

Share this post


Link to post
Share on other sites
lastejas

just a thought did you clear your browser cache after doing the update.

Share this post


Link to post
Share on other sites
Mark Kosinski

Yes cleared browser cache, tried Edge, Internet Explorer, Safari, Chrome and Opera all with the same result.

Share this post


Link to post
Share on other sites
Ken Roy
6 hours ago, Mark Kosinski said:

Query: SELECT cp_data.cpbaseID AS th, surname, givenname, relation, household, cplineno, lineno, censusYear, street, sex, race, age, birthdate, birthplace, fatherBthplace, motherBthplace, household,immigration, occupation, veteran, status, street, location, personID, nbrSlaves, nbrSlaveHouses, comments, cpdataID, yearsMarried, chborn, chliving, nationality, religion, tribal FROM cp_data LEFT JOIN cp_link ON cp_data.cpdataID = cp_link.cpdataID WHERE cp_data.censusYear = "1920" AND household LIKE "406" AND (cp_data.transcriptID LIKE "dbid=6061&iid=4384791_00%") AND cp_data.location = "Erie, Erie, Pennsylvania, USA" ORDER BY cp_data.transcriptID ASC, lineno+0 ASC

Column 'censusYear' in field list is ambiguous

Until, I get a fix out, you can eliminate the problem by going to Edit Options in the Mod Manager and change the option for

Return all members of household even though PersonIDs are not assigned. Defaults to (n).

from the default of n to y which will eliminate the LEFT JOIN from being added to the query and thus the censusYear is ambiguous error. 

Share this post


Link to post
Share on other sites
Mark Kosinski

Thanks Ken!  Works as you said.  

Share this post


Link to post
Share on other sites
Ken Roy

I will try to get new version that fixes the issue later this week, but now also need to get to the bottom of the issue being reported by Rick hooley as a conflict with the Sosa mod

Share this post


Link to post
Share on other sites
Ken Roy

Mark

I sent you a new Census Plus International mod version to beta test when the Return All is set to the default of n

Share this post


Link to post
Share on other sites
lastejas

Hi Ken

Just got in for lunch so while I have 5 mins will load the update and give it a run.

Share this post


Link to post
Share on other sites
lastejas

Ken,

Initial indications show that this has cured the problem with SOSA, but will give it a longer test run this evening.

 

Share this post


Link to post
Share on other sites
Ken Roy

Census Plus International v12.0.0.10a has been posted to resolve the problem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×