Jump to content
TNG Community
Sign in to follow this  
lachel

Family photos - showing arbitrary people

Recommended Posts

lachel

I've searched but can't seem to find anyone talking about this.  In the "Family" section of an individual, it seems to somewhat arbitrarily show photos related to spouses, children, and daughter/son-in-laws.  I can't find a place to change this.  I'm using template 9, if that makes a difference.

For example, this is the page is my paternal grandfather.  Under the "Family" section, there is one group photo that has him in it, but the rest are all photos are all of my mother... his daughter-in-law.  He's certainly not attached to any of these photos (except the group photo that he's in), I can't imagine why the site is pulling her photos to put here?  I don't really want any photos in the "Family" section that aren't of the person whose record it is. http://you.buhr.me/getperson.php?personID=12&tree=tree1 

That's just one example.  On the page for my father, is has my picture under the "family" photos, but no photo of my sister.  He's not in either of these photos, nor is he tagged in either of these photos.  So it seems somewhat arbitrary of what photos it's showing?

I do like having the "family" photo option, because I have a number of older wedding and engagement photos, but if the best solution is just getting rid of that field, I'm fine with that, too.

Thank you!

Share this post


Link to post
Share on other sites
bhemph

It looks like you don't have prefixes set up.  In the admin screen under Setup >> Configuration >> General Settings >> Prefixes and Suffixes is where those get set up.  I am guessing that everything is blank there.  The defaults are all prefixes:  Person = 'I' although some use 'P' to see it better plus the I is for Individual but person is the term used more in TNG, Family = 'F', Source = 'S', Repository = 'REPO', and Note = 'N'  Without having these, family 7 and person 7 are both linked as 7 to media and TNG cannot tell the difference between the photos attached to your paternal grandfather's family 7 and your mother's person 7.  With the prefixes, F7 and I7 or P7 are different and won't show up on the wrong page.

Share this post


Link to post
Share on other sites
lachel

Oh thank you.  That makes sense.  So to fix this, I would have to change the ID numbers for individuals and families to have either an P or an F at the beginning?  And there's no way to change ID numbers?  Oh dear.  Are there any other fixes?

Share this post


Link to post
Share on other sites
Ken Roy

You might want to use the TNG default values before attempt to change prefixes to other values, using uppercase values:

  • Person prefix:  I (capital eye)
  • Family prefix   F
  • Source prefix:  S
  • Repository prefix: REPO
  • Note prefix:  N

Share this post


Link to post
Share on other sites
lachel

I think the problem (part of the problem?) was that there were no default values?  I just followed bhemph's instructions and went and entered them.  But they aren't on any of the individual or family profiles I've entered so far.  So there's a person id 9 and a family id 9, and they seem to be sharing photos, because the IDs should be I9 and F9 to differentiate them.  I was searching this community, and it doesn't seem that there's an easy way to change ID numbers?  Does this mean I need to delete everything and start again?  :( 

Share this post


Link to post
Share on other sites
Ken Roy

Look at the Resequence IDs section of the Help screen in Admin > Utilities   I am not sure it will renumber with a prefix when no prefix was assigned in the first place. 

Make sure your prefix definitions are all uppercase and make sure you have a good database backup (TNG Admin > Utilities) before attempting this

Share this post


Link to post
Share on other sites
manofmull

I think there's something wrong with Lachel's site setup.

There doesn't appear to be any footer and the homepage link on the menu bar gives

http://you.buhr.me/Looking Back

404 Not Found
nginx/1.10.3 (Ubuntu)

 

Michael

Share this post


Link to post
Share on other sites
theKiwi

There are a number of things wrong it seems like. Looking at this page

http://you.buhr.me/search.php?mylastname=BUHR&lnqualify=equals&mybool=AND

Not only do the people listed not have a Prefix I on their numbers, some of them have a letter as part of the number - eg 

http://you.buhr.me/getperson.php?personID=24S1&tree=tree1

is personID 24S1

It might be possible to fix this by exporting a GEDCOM file, and then importing it into a software that will renumber everybody, and then exporting a GEDCOM file from that, and then importing that into a new empty database.

Roger

Share this post


Link to post
Share on other sites
lachel

Thank you everyone for your advice.  I tried to have a unique naming convention that would help me keep track of people, but I see now that TNG can't easily work this way.  I'm going to start going through and replacing people who are already entered with new records that have automatically generated IDs.

Share this post


Link to post
Share on other sites
manofmull

In your site Admin/Setup/Site Design and Definition/Genealogy URL  should be  http://you.buhr.me/

You need to remove the "Looking Back" part and then save

 

Michael

Share this post


Link to post
Share on other sites
lachel
2 hours ago, manofmull said:

In your site Admin/Setup/Site Design and Definition/Genealogy URL  should be  http://you.buhr.me/

You need to remove the "Looking Back" part and then save

 

Michael

When I did that, it just refreshes the page you're on when I click it.

Share this post


Link to post
Share on other sites
manofmull

Thanks for admin access. I've sorted your homepage link.

In Admin//Site Design, the index.php was missing

 

Michael

Share this post


Link to post
Share on other sites
lachel
37 minutes ago, manofmull said:

Thanks for admin access. I've sorted your homepage link.

In Admin//Site Design, the index.php was missing

 

Michael

Thank you so much!  It makes it much easier to navigate.

I really appreciate all of the kind help so far :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×