Jump to content
TNG Community
boonie67

SQL Error

Recommended Posts

boonie67

Testing upgrade to TNGv12.1 and have an error in Erik's Forum mod related to SQL maria database.

Query: SELECT threadID, forumID, threadDateTime FROM WHERE threadDeleted = 1;

You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'WHERE threadDeleted = 1' at line 1

This code snippet if from forum_index.php which is installed but has this error on the page.

Share this post


Link to post
Share on other sites
Ken Roy

Randal,

If this is an upgrade, why are you missing the table name in the query?  Or did you do a full install for your upgrade, in which case you need to define the tables needed by the mods that add new tables.

Share this post


Link to post
Share on other sites
boonie67

Ken,

Testing TNGv12.1.0  /  Problems solved! Posting if someone runs into this problem.

This was an upgrade, the solution was to remove all instances of forum folders in root and upload new forum installation and this time installed forum with the tng_forum table. After installation restored forum from utilities.

Installing Forum together with PAC has one problem, if done in the wrong order, the Info drop down menu is frozen and does not drop down Info menu.

Solution installing in this order PAC first and then install Forum second solves this problem. Using test site with all mods I use are installed with complete website folders, files (clone) as is on my website site.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×