Jump to content
TNG Community
GeoffH

Linking to Google Maps

Recommended Posts

GeoffH

I am having problems setting up Google Maps in TNG 12.1 and using WAMP. I get a blank event map for people whose places have a latitude and longitude.  In the right hand side of the event map I see events and if I click on the pin legend then Google maps comes up with the correct map but outside of TNG in https://www.google.com/xxx  Also I cannot get a response from Geocode.
I have read the help items many times and wonder if I have the correct site address which I have set to http://localhost/tng when the admin page is at http://localhost/tng/admin.php. I really get confused on restrictions and tried several attempts.
Thank you,

Geoff

Share this post


Link to post
Share on other sites
GeoffH

Clarification

I should have said when I click on the pin - not the 'pin legend'

Geoff

Share this post


Link to post
Share on other sites
stores

Geoff,  I have mine set in WAMP Admin to http://localhost/ which is where the index.php is. 

As far as the pins, that is how mine works and always has... if i click on a pin, then that place opens up outside of tng in another tab as https://www.google.com...

However, i also have the mod https://tng.lythgoes.net/wiki/index.php?title=Mapplace_To_Link_mod which makes the places the map pins point to clickable and those places open up inside of tng in another tab if i click the actual place and not the pin.

Jim

Share this post


Link to post
Share on other sites
GeoffH

Thank you Jim,

your first 2 paragraphs show that your site behaves the same as mine. When i saw the maps opening outside of TNG I thought I had made an error. Is this the way the Maps work when on a website as I see examples of maps showing within TNG?

I will now study how to load in mods and try the script that you give in the 3rd paragraph. 

Thanks again,

Geoff

Share this post


Link to post
Share on other sites
stores

You are welcome and yes, this is how the map works in TNG... Click a pin on the map and it gives a description, Click the pin on the right of the map and it opens that place in google maps in a new tab... Attached is how a map looks on my site with the mod installed i mentioned earlier. Jim 

Sample Map.jpg

Share this post


Link to post
Share on other sites
GeoffH

I have successfully loaded “Mapplace_To_Link_mod” and find no change from my previous experience. I suspect I am not properly linked to Google Maps.  Even if I enter 1234 as the API key in Map Settings I get the same behaviour as with a proper API key. This was after deleting the API key in Google and clearing my cache.

On my first attempt with Google Maps I got a response using Geocode but when my maps opened outside of TNG I thought this was in error so I deleted the first API key and got another – I must have done this about 8 times as I was unfamiliar with the subject. Never since this first API key have I got any response from GeoCode. Any suggestions please?

Geoff

Share this post


Link to post
Share on other sites
GeoffH

I gave up on Google and API and have now installed openstreetmap mod on TNG 12.1 and all behaving well. I am now seeing the maps within the TNG window and the event map is showing the pins. Many thanks to the developers of this mod.

Geoff

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×