Jump to content
TNG Community
Katryne

Public Access control in TNG 12.1

Recommended Posts

tngrlkrz

It's rather complicated, and not sure if I got this right, but it does install. I dont' use the mod so not sure how to test.  Give this a try.

***deleted file****

Ron

 

Share this post


Link to post
Share on other sites
tngrlkrz
26 minutes ago, Ken Roy said:

I need the complete zip file that includes the subfolder

 

Here's the original (I downloaded it earlier today without problem from wiki).

Ron

 

Public_Access_Control_mod_v12.0.0.1.zip

Share this post


Link to post
Share on other sites
tngrlkrz

I guess enough fingers in the pie....goodbye also.  One of the posted solutions should work for Katryne and Boonie.

Ken, you can take your pick, and make the necessary changes to Erik's wiki, if all goes green on this.

Ron

Share this post


Link to post
Share on other sites
Ken Roy
8 minutes ago, tngrlkrz said:

It's rather complicated, and not sure if I got this right, but it does install. I dont' use the mod so not sure how to test.  Give this a try.

public_access_control_v12.1.0.1.zip

Ron

Ron,

You and Jürgen are welcome to continue the effort.  I also do not use the mod but your posted version does NOT install if my Mobile Site Enhancements mod is installed.  I was only tryint to help while Erik is in the hospital.

Share this post


Link to post
Share on other sites
tngrlkrz
6 minutes ago, Ken Roy said:

Ron,

You and Jürgen are welcome to continue the effort.  I also do not use the mod but your posted version does NOT install if my Mobile Site Enhancements mod is installed.  I was only tryint to help while Erik is in the hospital.

Same here, just trying to help in his absence. Don't know if I can resolve today.  We need feedback to see if either of the postings works for Katryne or Boonie.  Erik really does a LOT of insert after before all over the place in this mod ~4000 lines LOL.  Hard to follow.  Did you try Jurgen's cfg file with Mobile Site mod? He took a different approach to the location: statements.  What is the line number error on it?  I do use that mod.

Ron

Share this post


Link to post
Share on other sites
tngrlkrz

Katryne,

Did you try Jurgen's ?? My version has an issue after uninstall.

Ron

Share this post


Link to post
Share on other sites
tngrlkrz

Ken,

I tried Jurgen's and it is compatible with Mobile Site Enhancements 12.1.0.4, both install OK.

Ron

Share this post


Link to post
Share on other sites
Katryne

I just tried your zip, Ron. It can install and be configured, but I get an error message on getperson

Parse error: syntax error, unexpected '}' in /homepages/18/..../htdocs/tng12/personlib.php on line 714

Share this post


Link to post
Share on other sites
tngrlkrz

OK, uninstall it.  I have an issue with it.  I've tried Jurgen's and it seems to install OK.  Try installing his cfg file.

Ron

Share this post


Link to post
Share on other sites
Ken Roy

Jürgen's version returns Bad Targets

ine 2240: %parameter:$xerxxCollHideIcons:false% 
line 2246: %location:% #8 not installed
line 2267: %location:% #9 not installed
line 2283: %location:% #10 Bad target
line 2301: %location:% #11 not installed
line 2319: %location:% #12 not installed
line 2341: %location:% #13 not installed
line 2363: %location:% #14 not installed
line 2380: %location:% #15 not installed
line 2397: %location:% #16 Bad target
line 2419: %location:% #17 Bad target

Only mods installed on that TNG 12.1 site are. OOPS - site is still at beta 1 so is missing the last set of fixes

Share this post


Link to post
Share on other sites
tngrlkrz
3 minutes ago, Ken Roy said:

Only mods installed on that TNG 12.1 site are. OOPS - site is still at beta 1 so is missing the last set of fixes

Yes, I updated my Wamp 12.1b to 12.1 and then Jurgen's installs OK with Mobile Site Enhancements.  My version has an issue and told Katryne to abandon it.

Ron

Share this post


Link to post
Share on other sites
Ken Roy

Just upgraded that site to TNG 12.1 and still get errors.  I am probably just too tired to think straight so I am going to bow out.  If you need help let me know.

Share this post


Link to post
Share on other sites
boonie67

I will test it on my test site and let Ron and Ken know.

 

Share this post


Link to post
Share on other sites
tngrlkrz
1 minute ago, boonie67 said:

I will test it on my test site and let Ron and Ken know.

 

Don't use mine.  Had an issue; it installs fine, but leaves something dirty after the uninstall because turns to 'cannot install' with a bad target at location 10.  Mod Mgr couldn't handle something I did.  Try Jurgens, since it seemed to install and uninstall clean, and with Ken's mobile site enhancement mod as well.  

Katryne, if you get a 'cannot install' after uninstalling my version, you may have to uninstall all mods, and then recopy(ftp if website)  TNG 12.1's personlib.php and getperson.php again, like you did earlier.  This is a long and difficult mod of Erik's.  May take more study if Jurgen's doesn't function properly.

Ron

Share this post


Link to post
Share on other sites
boonie67

I am using my own cfg file. Will let you know how it goes.

Did you check your PM I sent it has a Research Tool cfg file upgraded to TNGv12 standards?

Share this post


Link to post
Share on other sites
tngrlkrz
3 minutes ago, boonie67 said:

I am using my own cfg file. Will let you know how it goes.

Did you check your PM I sent it has a Research Tool cfg file upgraded to TNGv12 standards?

Confused. I haven't got any PM. Who are you addressing? Ken?  if it's Research Tools, it should go to the author, Scott du Prey, shouldn't it?  

Ron

 

Share this post


Link to post
Share on other sites
Ken Roy
1 minute ago, tngrlkrz said:

Confused. I haven't got any PM. Who are you addressing? Ken?  if it's Research Tools, it should go to the author, Scott du Prey, shouldn't it?  

Ron

 

Ron,

That comment was from boonie67. 

Share this post


Link to post
Share on other sites
boonie67

Ron,

 I am addressing you for the Research Tool cfg file. However you may want to test it. I had tested it but this file needs testing in all browsers you have. My thinking is it still needs some more work therefore test it if you have the time.

Share this post


Link to post
Share on other sites
tngrlkrz
8 minutes ago, Ken Roy said:

Ron,

That comment was from boonie67. 

I realize that, but who did he PM?  I'm merely guessing who he PM'd, thought maybe you.

Ron

It was to me, he forgot to send first time, testing something for Randal (and Scott?)

Ron

Share this post


Link to post
Share on other sites
tngrlkrz
5 minutes ago, boonie67 said:

Ron,

 I am addressing you for the Research Tool cfg file. However you may want to test it. I had tested it but this file needs testing in all browsers you have. My thinking is it still needs some more work therefore test it if you have the time.

I haven't got it.  I'd be happy to test it, just wondering why you didn't contact Scott first.  Yes, I did much testing for Scott on that mod.  

Unless you're instead talking about the Research Link mod??  I did offer support on that, ...to a point, but I am not the author.

Ron

 

Share this post


Link to post
Share on other sites
tngrlkrz

Slight correction...this now will install and uninstall properly on TNG12.1, and coexist with mobile site enhancement mod; .  The mobile mod must be installed last and uninstalled first.  But whether is does what is intended functionally,  that's up to current users to test.

public_access_control_v12.1.0.1.zip

Ron

Share this post


Link to post
Share on other sites
Katryne

I installed Jürgens cfg file. It can be installed, it can be configured, but it is not working as before.

When not connected, I can see a small thumb of the media, when hovering it, I see a larger thumb completely readable and only when I click on it I am asked to connect and i am barred from seing the media full size.

With previous release of TNG and the mod, I was not allowed to view at all any thumb, only an icon and a message to say I must connect.

Also, the French lang files that I had given Erik are not there.

Share this post


Link to post
Share on other sites
tngrlkrz
9 minutes ago, Katryne said:

I installed Jürgens cfg file. It can be installed, it can be configured, but it is not working as before.

When not connected, I can see a small thumb of the media, when hovering it, I see a larger thumb completely readable and only when I click on it I am asked to connect and i am barred from seing the media full size.

With previous release of TNG and the mod, I was not allowed to view at all any thumb, only an icon and a message to say I must connect.

Also, the French lang files that I had given Erik are not there.

You can try mine also, but I suspect it might have logical and functional issues as well.  Darrin put in some fixes or changes apparently, related to thumbs in the area of code that is giving Erik's mod a headache.  It's likely going to take someone who understands the functionality and knows how to change the cfg file to fix this.

You can check if the language files are in the one I sent you; it was downloaded this morning from Erik's wiki page.

Ron

Share this post


Link to post
Share on other sites
Katryne

No, Ron. Yours keeps giving a parse error :

Parse error: syntax error, unexpected '}' in /homepages/18/d.../htdocs/tng12/personlib.php on line 714 and get person page cannot be displayed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×