Jump to content
TNG Community
Jane Kneis

Template 10 - primary image + links problems

Recommended Posts

Jane Kneis

Good afternoon,

I need your help, I have change the primary image and on the front side of my homepage it is displayed correctly, but when I go to subpages it's not, where do I have to change the codes to view my
primary image correctly on the subpages?

I have one more small problem, when I add a link from the Danish church books (direct link to page) is the whole link not marked = not directly to the page https://www.sa.dk/ao-soegesider/da/billedviser?bsid=203400#203400,38575096

Thank you in advance

Regards
Jane

 

link.jpg

Primary_image_1.jpg

Primary_image_2.jpg

Share this post


Link to post
Share on other sites
theKiwi
1 hour ago, Jane Kneis said:

I need your help, I have change the primary image and on the front side of my homepage it is displayed correctly, but when I go to subpages it's not, where do I have to change the codes to view my primary image correctly on the subpages?

You probably need to edit the file topmenu.php also?

 

1 hour ago, Jane Kneis said:

 I have one more small problem, when I add a link from the Danish church books (direct link to page) is the whole link not marked = not directly to the page https://www.sa.dk/ao-soegesider/da/billedviser?bsid=203400#203400,38575096

 

You probably need to write to Darrin directly about this - it seems like TNG is stopping when it gets to the , in the URL?

Roger

Share this post


Link to post
Share on other sites
Jane Kneis

 

Hi Roger,

6 minutes ago, theKiwi said:

You probably need to edit the file topmenu.php also?

Thank you for your reply, but what do I need to add to topmenu.php when I open topmenu.php in DW there is only <body> can you help what code I need to add?

10 minutes ago, theKiwi said:

You probably need to write to Darrin directly about this - it seems like TNG is stopping when it gets to the , in the URL?

OK, thank you again, I will write to Darrin

Jane

Share this post


Link to post
Share on other sites
theKiwi

What is the URL to your website?

Roger

Share this post


Link to post
Share on other sites
theKiwi

I'm stumped - I don't know what has happened.

How did you change the image?

Is the new image the same dimensions as the original image?

Roger

Share this post


Link to post
Share on other sites
Ken Roy
1 hour ago, manofmull said:

I would have thought that problem was fixed for TNG12 but obviously not

Well problems do not get fixed in TNG unless they are reported to Darrin.

So if this is a TNG problem, you all need to report it to Darrin

Share this post


Link to post
Share on other sites
manofmull

Ken

Yes, I'd go with that, which is why I mentioned it to him in 2017

 

M

Share this post


Link to post
Share on other sites
Ken Roy
On 2/20/2019 at 12:19 PM, Jane Kneis said:

when I open topmenu.php in DW there is only <body>

If DW means DreamWeaver, that is not a good way to edit TNG files, since DreamWeaver will add things it thinks are missing in order to create a web page.

TNG builds pages using different code snippets.  It is best to use an ASCII text editor like Notepad++ in Windows and TextWrangler in a MacIntosh environment. 

See How TNG builds a page and other pages in the How TNG Works category

Share this post


Link to post
Share on other sites
Jane Kneis
18 hours ago, theKiwi said:

I'm stumped - I don't know what has happened.

How did you change the image?

Is the new image the same dimensions as the original image?

Roger

Hi Roger,

Have change the size to 420x150 and now it works OK on frontpage and sub pages, but a little annoying to be locked onto 420x150 - but i works now

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×