Jump to content
TNG Community
Appelmus

tng 12 custom menu

Recommended Posts

Appelmus

Hello - another problem!

A friend has set up in my tng 12 another menu item "Test". (PICTURE).

Menue.jpg

 

All necessary information is made in the customconfig.php (picture)

customconfig.jpg

There, the link-target must be specified. I have tested all path variations.
For example: /eigene_dateien/datei01.php or /htdocs/eigene_dateien/datei01.php or / test-tng / htdocs / eigene_dateien / datei01.php etc.
I finally entered the whole path in the line. I always got the error 404 with the remark that the file was not found.

What am I doing wrong?

Best regards

Appelmus

Share this post


Link to post
Share on other sites
Appelmus

What does  "relative to your genealogy URL " mean
I tried the entire path of the URL in ever longer pieces. Unfortunately to no avail.
The arrow in the second image shows the entire path. What of this is relative?

best regards

Appelmus

Share this post


Link to post
Share on other sites
Ken Roy

Your Genealogy URL is defined in Admin > Setup > General Settings in the Site Design section

If the file is in your TNG root folder, then you only specify the file_name

If the file is in a TNG subfolder, such as histories, then the target should be specified as folder/file_name

Relative path means in relationship to your TNG folder

Edited:  More accurately it is in relationship to your Root Path in the Paths and Folders section of the General Settings

Share this post


Link to post
Share on other sites
Appelmus

Thank you, ken - here it is 00:35 (11.2.2019) o 'clock and I go to bed. 🙂 

Share this post


Link to post
Share on other sites
Appelmus

There must be another reason. The path, specified under settings, corresponds to the one shown in the picture above. He ends .... / htdocs. In the customconfig.php I have to enter only the directory and the file name. e.g. /eigene-Dateien/datei01.php. That's how I did it, but always get the error message that the file was not found.

Is there a solution for this world riddle 🙄

Ps

Attached is a section of the customconfig and the path-

/var/www/virtual/geschichtswerkstatt-lammersdorf.de/test-tng/htdocs/

F4D6617C-6FB4-4D4B-907C-CCEBBA7B884C.jpeg

Share this post


Link to post
Share on other sites
Ken Roy

Why do you have a leading slash in your target?

Maybe you should ask the question on the German user list if you do not understand the English meaning of a relative link.  I am guessing because I have no clue what your file name is and in what folder it is location in relationship to where your TNG files are located.

Share this post


Link to post
Share on other sites
Appelmus

Let me summarize:
(a) This is the root path specified in the settings

Bildschirmfoto 2019-02-11 um 22.48.35.png

The website test-tng is a subdomain


b) relative to this path, I specify the location where the file can be found. There is no slash there

Bildschirmfoto 2019-02-11 um 22.49.53.png


c) If I test the menu, the error message appears with slash

Bildschirmfoto 2019-02-11 um 22.50.36.png

Share this post


Link to post
Share on other sites
theKiwi

What is your Genealogy URL set to? (under the site design and definition settings area)

It seems like this part

image.png

is wrong - the /geschichtswerkstatt-lammersdorf.de - is that your domain name?

Roger

Share this post


Link to post
Share on other sites
Appelmus

I got it. The error lay in the rewritten historytemplate.php. Tomorrow I will analyse this in more detail.

Thank you for your engagement.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×