Jump to content
TNG Community
pipsi

v. 12.0.2 / č and ř in header title, part 2 & welcome paragraph (template 4)

Recommended Posts

pipsi

hello from Vienna!

since the upgrade from v. 11.1.2 to v. 12.0.2 a few weeks ago, č and ř are not shown in the header title, part 2 or welcome paragraph. 
I have already corrected it several times under setup/template settings - see att. photo! These special characters are displayed correctly for Czech names (database).

What do I have to do?

http://www.schuster-pippersteiner.at/genealogie/TNG/index.php

Happy New Year and kind regards,
Ingrid

 

TNG_20190101.PNG

Share this post


Link to post
Share on other sites
Ken Roy

Ingrid,

You need to make sure that all charset definitions on your site are either all UTF-8 or all ANSI. Looks like you might be using the wrong Czech folder.  If your database collation sequence is utf8_xxxx then your TNG Admin > Setup > General Settings > Languages should be Czech-UTF8 and the charset be UTF-8  your other Admin > Languages also need to be UTF8.

Or if your database is using latin1_xxxx collation sequence, then you need to use the non-UTF8 language folders

Share this post


Link to post
Share on other sites
pipsi

Ken,

these are my language settings - see attachment
I already used it with v. 11.1.2 - and didn't change anything after the upgrade to v. 12.0.2, at least not consciously ;) 

additionally - the czech language setting works everywhere else, but not in template settings

e.g. see here
http://www.schuster-pippersteiner.at/genealogie/TNG/getperson.php?personID=I290&tree=SchuPipp

Ingrid

UTF-8.PNG

Share this post


Link to post
Share on other sites
theKiwi

Can you check your database using phpMyAdmin from your cPanel and see what collation the different tables and fields in the database are set to? In particular the tng_templates table and its fields - are they the same as the other tables and their fields?

They should be set to something like utf8_xxxxxx_ci if you're using UTF-8 for the language folders 

It might be that the template settings are not being saved as utf8_xxxx_ci that is causing these problems.

Roger

Share this post


Link to post
Share on other sites
pipsi

I'll check! thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×