Jump to content
TNG Community
Appelmus

Domain with and without index.php

Recommended Posts

Appelmus

Hello and a happy new year!

A first question from an IT newcomer:
I just installed the program TNG. If I now enter the domain name into the browser without /index.php, I will get a blank page with the note  "Site under construction " With attached /index.php the website is shown correctly. What should I do to ensure that the website is displayed correctly without an index.php?

Appelmus

PS 

I read the related explanation in the manual. But I'm an absolute novice, so I can not do anything with it.

Share this post


Link to post
Share on other sites
tngrlkrz

The note on the blank page isn't appearing in your post.  It should not be necessary to append "index.php".  Automatically should search for index.php being present in your TNG root folder.  What version did you install?  Did you setup an admin user?  Go to admin:setup:paths and folders: root path is set to your domain properly.

Ron

Share this post


Link to post
Share on other sites
theKiwi

This is probably a setting on the server, combined with your site also having an index.htm(l) file - if there is such a file on your site, delete it and leave behind the index.php file.

The reason for what you're seeing is a setting telling the web server if it's not asked for a particular file to first give out index.htm(l) if it exists.

Roger

Share this post


Link to post
Share on other sites
Appelmus

Thank you both. After deleting an index.html, it works.

Excuse me to my cluelessness

Appelmus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×