Jump to content
TNG Community
Katryne

Reports won't display in TNG 12.0.3

Recommended Posts

Katryne

Hello !

What should I do to display the reports now ? With 12.0.3, a click on the Report link gives this error :

Requête: SELECT reportname, reportdesc, reportID FROM tng_reports WHERE active = 1 ORDER BY rank, reportname
Unknown column 'rank' in 'order clause

In 12.0.3 changelog, I read :

• Reports: Changed the name of the "rank" column in the tng_reports table to "ranking" because "rank" is now a MySQL keyword (throws an error in MySQL 8.0).

 

Thanks

Katryne

 

 



 

Share this post


Link to post
Share on other sites
Ken Roy

Katryne,

You need to update the reports.php script at line 8 to use

$query = "SELECT reportname, reportdesc, reportID FROM $reports_table WHERE active = 1 ORDER BY ranking, reportname";

I will send an email to Darrin so he can fix the code.

Share this post


Link to post
Share on other sites
Katryne

Hi Ken ! I wrote to him this morning, but I must have selected a bad address and the email came back to me.

Thanks for the fix.

(It's line 18, not 8  : well , it's line 18 in one of my TNG and line 8 in the other. One of my sites is not up to date ? What did I do ?)

Share this post


Link to post
Share on other sites
Katryne

I was an early adopter of TNG 12.0.3 and Darrin had modified the file moments after I downloaded it. He just sent me the correct reports.php, the one that is presently included in the available download.

Thank you everybody. Everything is in order now.

Share this post


Link to post
Share on other sites
stores

Yes, Darrin often changes the files in the core downloads of a version, especially the first few weeks or months after a new version is released... I routinely download the full install every once in a while, especially if people are pointing out problems that have been fixed, and then i sort the zip file by "Date modified" as this will show the date the of the files. Then i just replace my files with these updated files... This is why my signature reads TNG v11.1.2 (of 23 October 2017) as 23 Oct 2017 was the last time a file had been updated in v11.1.2. Keep in mind, this occasionally causes my mods to revert to partially installed, if so, i just cleanup the mod and reinstall it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×