Jump to content
TNG Community
Sign in to follow this  
pelar

Update v9.x to v12.x gone wrong

Recommended Posts

pelar

I just upgraded from from v9.x to v12.x and followed the exact steps in the read me manual, but now I find myself confronted with a white screen that says: 'Administrator-No-Users-Yet is not a valid user'. I think there's something wrong with trying to connect to the database. So the following things are checked and correct:

1. Database-name, login and pass in the config-file
2. Checked and repaired the SQL-database
3. Checked the users in the SQL-database and they're still correct
4. Tried PHP5 and PHP7, but still the same white screen
5. Edited the config-file maintainance from "" to "1" and back to ""

Any other suggestions or help from you guys? 

Regards,

Peter

Share this post


Link to post
Share on other sites
Ken Roy

Peter,

Did you use the upgrade zip file or the full install zip file? 

White screen typically indicate syntax errors or in some case a File not Found condition.

Share this post


Link to post
Share on other sites
pelar

Used the upgrade zip. Somehow I now managed to log on to the website, but the records still won't load.

Edit: Nevermind. I think the database or server had to have some time to get things straight. Now my Wordpress integration is messing some little things up. Looks like TNG itself is working fine now.

Edit2: Looks like the Akosay template wasn't working anymore with the TNG-integration. Switched to the Twenty Twelve template and (apart from little css-details) everything is working fine now. 

Share this post


Link to post
Share on other sites
pelar

Ok, I need to update this one. If I could, I'd like to change the title of this topic to: "Administrator-No-Users-Yet is not a valid user", because that's the error I keep getting when visiting any TNG-page that's integrated on my website. I just don't get it. The one browsers it works (like Chrome right now), but on Explorer it won't, same goes for Safari on the iPad, while I cleared the cookies and stuff on all of them.

So the integrated version is http://stamboom.petervalstar.nl/genealogie/searchform.php and the standard TNG-version on http://stamboom.petervalstar.nl/tng/searchform.php.

Again, I did the following things:

1. Checked database-name, login and pass in the config-file
2. Checked and repaired the SQL-database
3. Checked the users in the SQL-database and they're still correct
4. Tried PHP5 and PHP7, but still the same white screen
5. Edited the config-file maintainance from "" to "1" and back to ""
6. Cleared/deleted cookies and stuff.

And I think it may have something to do with changing the PHP-version, because the provider demanded me to upgrade to PHP7. PHP5 won't be provided any longer from 2019.

Any advice? And I'm really interested if the provided links are working for you guys.

Edited by theKiwi
Fixed second link to correctly point to /tng/

Share this post


Link to post
Share on other sites
pelar

And now I cleared the cookies of Chrome (where accessing the database was working because I tried a couple of searchstrings, places, etc.) and now I get the same "Administrator-No-Users-Yet is not a valid user" there as well. 

Cleared it again and now it works. Looks like it just randomly picks up the right settings or something? This only works for Chrome, Safari just doesn't pick the website/database up, even after the cookies are deleted.

So still, something on the PHP-version?

Share this post


Link to post
Share on other sites
theKiwi

If you are using the TNG-WordPress -plugin, then you can NOT have checked the option to "Integrate TNG/Wordpress logins:". If this is checked you will get 500 Server errors - i.e. an empty white page - this option MUST remain unchecked.

But I just tried both of your links, and both of them work for me on Mac OS X Safari - I can do a search for last name starts with van and it returns 1,553 results.

Roger

 

Share this post


Link to post
Share on other sites
pelar

The "Integrate TNG/Wordpress logins" option is turned off, so that isn't/wasn't the problem. 

Funny thing is that I managed to access the database as well a minute or so ago, but now it's again giving me the "Administrator-No-Users-Yet is not a valid user" message. 

Now, when that message appeared again, I emptied the browser history/cookies, and then the TNG-database is accessable again and giving me search results. 

It looks like the cookies are messing things up after a few minutes or so?

Edit: And there it happened again, same ""Administrator-No-Users-Yet is not a valid user". By the way, I was using Safari on the iPad/iphone. Never managed to get on the website on that browser since the update, while Chrome on the iPad worked for a few minutes and then gives me the same message just like explained above.

Edit 2: I must be crazy or something. Didn't change anything, apart from emptying some browsers cookies and now it looks like they can all access the website. We'll see for how long ;)

Share this post


Link to post
Share on other sites
pelar

And another update. Tested it on different devices, after deleting cookies and they give me the following results:

- iPad, Safari: doesn't work, gives me Administrator-No-Users-Yet is not a valid user (even after deleting cookies)
- iPad, Chrome: does work!
- Desktop, Chrome: doesn't work, gives me Administrator-No-Users-Yet is not a valid user (even after deleting cookies)
- Desktop, IE11: does work!
- iPhone, Safari: doesn't work, gives me Administrator-No-Users-Yet is not a valid user (even after deleting cookies)
- iPhone, Chrome: does work, but when I tried to go to the admin section I got the error again, then deleted the cookies and actually managed to get into the admin again.

The only url that works, even on the devices/browser that give me "Administrator-No-Users-Yet", is tng/admin_login.php.

Still lost in the dark...

Share this post


Link to post
Share on other sites
Chris Lloyd

Sounds to me as though you need to contact the support section of your hosting provider. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×