Jump to content
TNG Community
Kristin

Characters language

Recommended Posts

Kristin

Hello. I have just started with TNG.   My site is in Norwegian. Norwegian has three more letters than English, æåø. The database and the text on the frontpage display these Norwegian letters. So everything is fine except for "Histories" (perhaps others too, like "Documents", but I have just tried "Histories").  In History-files the system does not recognize ÆÅØ, and writes a "?" insted,  I just wonder if the files for "Histories" is set to English, and not possible to change to other character sets without changes the file directly. Or if I have messed up something.

Share this post


Link to post
Share on other sites
theKiwi

What is the URL to your site?

Are you entering your data into TNG directly, or import a GEDCOM file?

What character set do you have TNG set for?

What is the collation of the database - you can find this out by looking in your cPanel ------> phpMyAdmin and then look at the tables of the database.

Roger

Share this post


Link to post
Share on other sites
Kristin

Hi!  The database is OK. Names show with æ ø å. The info I write to "Setup" is OK.  The problem is the files for "histories".  I use template 15. If I write in, for instance, histories/feature1.php, this file, or rather my file, histories/myfeature.pht, it will not show Norwegian signs. 

Share this post


Link to post
Share on other sites
cfj
5 hours ago, Kristin said:

I use template 15. If I write in, for instance, histories/feature1.php

I  have also Norwegian and Swedish letters and tested it with template 15. Everything works fine at my test site.

Can you take a look at your source code. Here is mine:

<meta http-equiv="Content-type" content="text/html; charset=UTF-8" />

If you can provide a link to your site, it could help.

Share this post


Link to post
Share on other sites
bhemph

When you make the histories files are you saving them as UTF-8 without BOM?

Share this post


Link to post
Share on other sites
Kristin

Thank you all.

There is a template called "featuretemplate.php" with instructions meant for Histories and Documents. I have followed the instructions and saved the file as php under a new name - MyHistory.php.  Then I link to the MyHistory.php in the Setup/template.  I can link to an ordinary html-file without any problems, but then I will not have the menu, design, and so on, on History pages.

My page is not public yet, so it is difficult to link to it.

Share this post


Link to post
Share on other sites
theKiwi

When you are editing the file, what software are you using for this?

When you save the file, you need to save it in the same collation as your TNG is set to run - so if you have TNG set to use UTF-8 (look in TNG Admin ------> Setup ------> General Settings ------> Language to find out if you're using UTF-8 or ISO-8859-1), then you need to save the .php file in the same collation.

This page on the TNG Wiki shows how to set this in the Macintosh software TextWrangler (which has been replaced by BBEdit) with links to other software for Windows users

https://tng.lythgoes.net/wiki/index.php?title=TextWrangler

Roger

Share this post


Link to post
Share on other sites
Kristin

I use Notepad++ It seems to be solved now. Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×