Jump to content
TNG Community
august

Sort dates partners/spouses

Recommended Posts

manofmull

There's two ways to do this.

Admin >> Import/Export >> Secondary Processes >> Sort Spouses

or you can do it manually (as I do)

Click on edit for Ole Jørgen Falch Figenschou  and scroll down to his two spouses/partners. You can then drag them into order and save.

 

Michael

Share this post


Link to post
Share on other sites
Ken Roy
1 hour ago, august said:

How do I define the Partner Custom Event Type (from gedcom) in order to have it sorted chronologically with spouses? In the following example a partner from 1932 is listed as Family 1 and the wife from 12 Oct 1918 is listed as Family 2:

If you are importing data, there is no need to Sort Spouse or Children after an import.  They should be set to the correct order in your genealogy program.  I have never used the Secondary Process > Sort Children or Sort Spouses.  If they are not in the correct order, I fix the order in my desktop program.

Share this post


Link to post
Share on other sites
august

I have tried the Sort Spouses but it doesn’t fix the problem. Dragging them manually into order will be overwritten by the next gedcom import.

The dates are in perfect order in my desktop program (TMG 9.05).

Share this post


Link to post
Share on other sites
Ken Roy

TNG normally preserves the order of children and of spouses on import.  Maybe TMG does not export them in order.

Share this post


Link to post
Share on other sites
stores

I have never had to sort spouses either, they are in the correct order in my genealogy program and retain that order in TNG... I do however "Sort Children" after I import a new gedcom because at least one of the mods I have installed requires it. Tables of Descendants is one mod that comes to mind because if a person has children it will not show a "Yes" in that column unless you do a "Sort Children" after importing a new gedcom. I also run "Track Lines" as well because that is needed as well because of a mod.

Share this post


Link to post
Share on other sites
Ken Roy

Jim,

That has not been my experience with the Tables of Descendants mod.   As far as I know the mod works correctly, but maybe I have not checked closely enough.

You do have to run the "Track Lines" after an import

Share this post


Link to post
Share on other sites
august

Even if the sort order was wrong in my desktop program, I do not understand why the sort order is still wrong after I run the Sort Spouses in TNG.

Share this post


Link to post
Share on other sites
manofmull

The order is still wrong because of this 

Partner 1932 

The year should be alongside "Married"

 

Michael

   

Share this post


Link to post
Share on other sites
august

They had a child in 1932, buy they were not married (TMG uses the event type Partner).

Share this post


Link to post
Share on other sites
stores

Ken, the mod works fine and I love it but on the right side of the page is the descendants, for the particular generation you click on and you have a childrens column, to show a person has children. That column is blank, instead of having a Yes in it, unless you run the "Sort Children" option when you import a new gedcom. At least that is what I have to do. 

Share this post


Link to post
Share on other sites
stores

Must be something with my (Offline) site... I have always needed to Sort Children before Yes would appear, after uploading a new gedcom.

Share this post


Link to post
Share on other sites
jayat1familytree

August

If you can look at the data in your database thru your phpmyadmin, then look up the marrdatetr in the tng_families table for your two marriages...

F44942  and F 44943

I dont use Year only dates but instead would use Abt. 1832 , you might try changing your desktop program to that and then see if the import sorts it properly.

Hope that helps.

Jay

Share this post


Link to post
Share on other sites
manofmull

I thought this was just a case of TNG not recognising the TMG event type "Partner"

i.e. if "Partner" was left as the default "Married", then it would work surely.

For something like this, I just put "unmarried" alongside "Married"

Share this post


Link to post
Share on other sites
august
15 hours ago, jayat1familytree said:

August

I dont use Year only dates but instead would use Abt. 1832 , you might try changing your desktop program to that and then see if the import sorts it properly.

Hope that helps.

Jay

Thank you, I tried this, but it doesn’t help.

Share this post


Link to post
Share on other sites
jayat1familytree
10 hours ago, august said:

Thank you, I tried this, but it doesn’t help.

what are the contents of the marrdatetr in the tng_familes table?

 

 

Share this post


Link to post
Share on other sites
august
3 hours ago, jayat1familytree said:

what are the contents of the marrdatetr in the tng_familes table?

 

 

Family 1 has the value 0000-00-00. “Partner” is a custom event type defined in my desktop program TMG.

 

Family 2 has the value 1918-10-12.

Share this post


Link to post
Share on other sites
bhemph

That being all 0 isn't right.  What is in the GEDCOM export for the family?

Share this post


Link to post
Share on other sites
august
1 hour ago, bhemph said:

That being all 0 isn't right.  What is in the GEDCOM export for the family?

I updated my TMG database with other info, and after a new export the family numbers are F44943 and F44944:

 

0 @F44943@ FAM

1 HUSB @I147780@

1 WIFE @I150122@

1 CHIL @I147782@

1 EVEN

2 TYPE Not Marr

2 DATE ABT 1932

0 @F44944@ FAM

1 HUSB @I147780@

1 WIFE @I147781@

1 CHIL @I150125@

1 CHIL @I150126@

1 MARR

2 DATE 12 OCT 1918

2 PLAC Tromsøysund, Troms

2 SOUR @S178@

3 PAGE https://media.digitalarkivet.no/kb10811410120288

 

 

Share this post


Link to post
Share on other sites
bhemph

So it is exported as a custom event, which explains why TNG gives the all 0 date.  My desktop program renumbers all the family numbers on each export in the order they are listed in the program, so I don't run into this issue but instead run into media attached to the family jumping to another family at each import.

Try editing that marrdatetr to 1932-00-00  that should allow the sort spouses to work as expected.

That gives you a couple of options.  If there are not too many that you would have to manually adjust and you are not importing too often, you could keep the list of which ones need to have the marrdatetr manually changed before running the sort and fix them that way.  Otherwise, you could add a mod to the import code to identify your custom event start date and run an update so that the marrdatetr is populated from the custom event start date if it is all 0.

Share this post


Link to post
Share on other sites
august

I see that TNG released a new version 12.0, maybe it’s a good idea to install this before I decide what to do next.

Share this post


Link to post
Share on other sites
jayat1familytree

I my Gedcom created in a Legacy Desktop database the "marriages' that are marked as "Partners" are exported  in the gedcom as a marriage record with the 'type" partners' and then both a standard marriage and the partner relationships sort properly by the date

0 @F9003@ FAM
1 HUSB @I26411@
2 _PREF Y
1 WIFE @I26384@
2 _PREF Y
1 MARR
2 DATE Aft 1960
1 _TAG
1 _TAG9
1 CHAN
2 DATE 1 May 2010
3 TIME 16:41

0 @F9004@ FAM
1 HUSB @I26430@
1 WIFE @I26384@
2 _PREF Y
1 _STAT Partners
1 MARR
2 DATE Aft 1960
2 TYPE Partners
1 _TAG
1 _TAG9
1 CHAN
2 DATE 1 May 2010
3 TIME 16:41
0 @F9005@ FAM

 

example_marriage_sort.jpg

database_look_marriages_partners.jpg

 

 

Hope that helps

Jay

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×