Jump to content
TNG Community
Joyaa

Database collation. French accents. Polish Lettering

Recommended Posts

Joyaa
2 minutes ago, theKiwi said:

for some stuff that will make your head hurt LOL

"One finds that one is no stranger to a hurting head these few days past ... "       :shock: 

Thanks Roger.

Share this post


Link to post
Share on other sites
Joyaa

Before I change any field data types (and match them precisely with the definitions given in tabledef.php) please can someone - possibly someone using ICDSoft and utf8_swedish_ci, but that may not be necessary - kindly go to their "phpMyAdmin", go directly to their "Variables" tab (which is within their "localhost" server), and scroll down to  "character set client".

Then please compare what you see there for twelve (12) values from "character set client" to "collation server" with the image below.   Do they match?  I want to be sure that there aren't other glitches in my set-up.

THANK YOU!

myPhpAdmin_8-after 100318 restore,thenSwedish PHOCA.jpg

Share this post


Link to post
Share on other sites
Ken Roy

Joyaa,

I have never looked at that tab in phpMyAdmin before and am not sure that it has a bearing on the issue.  I have certainly never changed any of those values 

When I looked at it just now it appears to be displaying latin1_swedish_ci in several places even though my databases are defined as utf8 with a collation sequence of utf8_swedish_ci

I documented a long time ago how to create a UTF-8 database on ICDSoft.  As far as I know that information is still valid.

Share this post


Link to post
Share on other sites
Joyaa
4 minutes ago, Ken Roy said:

Joyaa,

I have never looked at that tab in phpMyAdmin before and am not sure that it has a bearing on the issue.  I have certainly never changed any of those values 

When I looked at it just now it appears to be displaying latin1_swedish_ci in several places even though my databases are defined as utf8 with a collation sequence of utf8_swedish_ci

I documented a long time ago how to create a UTF-8 database on ICDSoft.  As far as I know that information is still valid.

Thanks Ken.   So long as the 12 lines under your "variables" tab match mine, then I may feel confident that something is working okay.   I am in two minds as to whether to go with changing the field types or setting up a new database.

But yes, I already have that database creation page open on my screen ...  In addition to following its (very clear guidelines), will I need to -- 

* rename my current database (let's say it's DB) to DB_OLD, then name the new one to DB ?
* then can I simply restore the data using TNG Utilities?  (I believe the data itself is fine).
reinstall Mods?
* re-modify my template 8 etc?  .. or is this info completely outside of the database?
* and re-modify my home page?

Lastly, when I set up the new DB, may I set up the first user for it with the same username & passw as the old database?    If so, when I restore the data, would I expect to find two users with the same name/passw?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×