Jump to content
TNG Community
stillman

Help to organise the update of my site

Recommended Posts

stillman

I use a Genelogical program on my computer that changes the reference IDs each time I update my database ...
So every time I want to update TNG with my new gedcom generated by this program, I lose all the links I could create in TNG.
How to solve this problem ?

Before importing my gedcom into TNG, I make a backup of all my tables.
I go to the configuration menu and I do "creation of tables" to go on empty tables.
I then import my gedcom by selecting "All current data" I recover most of what I envy. So I have an updated tree !
I'm restoring some tables like "Branches, Languages, Timeline Events, Trees, Users".
I update the "Media" and recreates all the thumbnails.

But I lose all "Albums", "Collections" and "Histories" create previously ....

Is my procedure good?

I do not find the way to save for example "collections" or "Histories" before doing an update via gedcom.

What do you recommend (except to change my computer genealogical software) ?

Share this post


Link to post
Share on other sites
Ken Roy

You should not start with a new database every time you do an import.  Go to Admin > Setup > Import Settings and change the default option to Replace All Data.  See the Import Data wiki article on an approach for doing imports and backing up our data.

Which software are you using that generates new IDs on export?  In some software IDs get reused if you do merged or deletes.

Share this post


Link to post
Share on other sites
stillman

Thank you for your answer Ken,

My program is Heredis 2018 Pro (for Mac), they are on the good way to improve their products to fit with gedcom standard (they have ask help to familyresearch...)

I try to fit my data in Heredis to be able to eploit the powerfull  of TNG, but it is not simple for me ...

Share this post


Link to post
Share on other sites
stillman

I forgot to tell you if I follow the Import Data wiki article, It creates a mess with media (course of Media ID change).

I need to clean each time the media who are not anymore linked.

I do not not understand why it takes ages to do an import of gedcom in TNG and most of the times it's blocked...

Share this post


Link to post
Share on other sites
theKiwi

You probably need to delete all the Media before you do your import given the other conditions you state.

That way the media will be imported from the GEDCOM file linked to the correct people.

Roger

Share this post


Link to post
Share on other sites
stillman

Super !!! I would need to delete about 2 900 medias before gedcom import  each time .... and lost personalisation as well

And what about a possible back up of Histories and Collections, is there a solution to keep them ?

Share this post


Link to post
Share on other sites
theKiwi
5 hours ago, stillman said:

Super !!! I would need to delete about 2 900 medias before gedcom import  each time .... and lost personalisation as well

And what about a possible back up of Histories and Collections, is there a solution to keep them ?

Well my honest view is that if you want to use a desktop software and TNG to publish it online, you need use a software that doesn't change the ID number of everybody every time you export a GEDCOM file. From the sounds of it that means ditching Heredis and using something else.

Heredis is the only software I've heard of that does change everyone's ID number every time you export a GEDCOM file.

Roger

Share this post


Link to post
Share on other sites
Ken Roy

Maybe it is not the Heredis export but the Ancestris software that is not preserving the IDs on Import based on your documented procedure in Desktop Gotchas

Share this post


Link to post
Share on other sites
stillman

Unefortunately It's really Heredis who does not preserving the IDs on export (for the moment !).

I was speaking about a direct gedcom export through Heredis without any manipulation with Ancestris.

I am in contact wiht Heredis team and I know that they have in their base a unique reference ID but they do not use it in the export gedcom file... Why I did not know ???

I am waiting for an answer since some while now.

In the meanwhile, I try to find solution for publishing pages that are not link with my base (see my first ask).

Share this post


Link to post
Share on other sites
reesjel

@stillman I recently purchased TNG to display my family tree online and use Heredis as well. I didn't know this was an issue. Do you know if this has been solved yet?

I haven't done anything yet aside from uploading the Gedcom and media and am running into some issues with the media, but it's good to know that making additions in TNG might not stick. I'll focus on importing and updating the gedcom first before I head into other issues.

Share this post


Link to post
Share on other sites
Katryne

Hello !

I met 3 different problems with importing my gedcom from Heredis :

  1. prefix/suffix in ID were not standard and I had to use an extra software (Free copy of RootsMagic) to rename all the IDs for individuals and families. It had a consequence with medias that could to be attached to individuals.
  2. for locations, latitude and longitude were entered with comas instead of periods And my maps were blank.
  3. Heredis had created useless events that were not standard for each of my ndividuals and for each families. For the moment being, I manage to hide them from display. When I edit  individual or a family, I delete this useless events, but it's a long run with 5000 persons and 2000 families.

Share this post


Link to post
Share on other sites
reesjel
On 8/7/2018 at 8:25 PM, Katryne said:

Hello !

I met 3 different problems with importing my gedcom from Heredis :

  1. prefix/suffix in ID were not standard and I had to use an extra software (Free copy of RootsMagic) to rename all the IDs for individuals and families. It had a consequence with medias that could to be attached to individuals.
  2. for locations, latitude and longitude were entered with comas instead of periods And my maps were blank.
  3. Heredis had created useless events that were not standard for each of my ndividuals and for each families. For the moment being, I manage to hide them from display. When I edit  individual or a family, I delete this useless events, but it's a long run with 5000 persons and 2000 families.

Hi Katryne,

Thanks for letting me know. So far I haven't had any issues with locations, so I guess they probably changed that in the gedcom export cause it works now. I haven't used prefixes yet I think, but it's good to know that there could be an issue with that. As for the useless events, I did notice I was missing some event info in my import, I'll check out the link you posted to.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×