Jump to content
TNG Community
  • 0
Scott Kampen

Multiple spouses not showing up

Question

Scott Kampen

Hello, forgive me if this question has already been addressed.  I am a new user to TNG and recently installed it at my site.  I have uploaded my current database (GEDCOM) file and have been setting up my site.  What I noticed was when I look at the Pedigree chart for a family member who has had multiple spouse and/or children from different spouse, I don't see the secondary spouses listed.

Here is an example with fake names of what I am talking about.

Dads name = Bob
First spouses name = Sally
Child 1 = Joe
Child 2 = Betty
Parents divorced

Bob marries someone new

Second spouses name = Mary
Child 1 (for this relationship) = Nick

Summary:  Bob had three children from two different marriages.  However, when I look at the Ancestry chart for Bob (husband) it only shows the information for the first marriage and the children from that marriage.  The second wife and child aren't in any reports associated to Bob.

I use RootsMagic version 6 to maintain my database and information and within that I can see all associated spouses and children for people.  How do I get TNG do show the same in reports for a person who has been married multiple times and has children from those relationships?

Hope this wasn't too confusing.  Thanks for your time and consideration to this question.

Scott

 

 

 

Share this post


Link to post

8 answers to this question

Recommended Posts

  • 1
jayat1familytree

Scott, it is always helpful here to list a link to your site where the problem shows.

Two initial thoughts,

First, after you imported the gedcom , did you run the "secondary process' called 'track lines"?

Second, Are you sure the original gedcom data has the families connected?

Open your gedcom in a text editor like Notepad++ and look for the section like this;

0 @F1581@ FAM
1 HUSB @I11686@
2 _PREF Y
1 WIFE @I868@
2 _PREF Y
1 DIV Y
2 DATE Aft 1983
1 MARR
2 DATE 2 Nov 1968
2 PLAC Kaukauna, Outagamie, Wisconsin, USA
1 CHIL @I11687@
2 _PREF Y
1 CHIL @I11689@
1 CHIL @I11690@
1 CHIL @I11691@
1 CHIL @I11692@
1 CHAN
2 DATE 16 Aug 2017

Make sure the details are correct.

Hope that helps,

Jay

 

 

Share this post


Link to post
  • 1
jayat1familytree

Admin>Import>Secondary Process

 

 

Share this post


Link to post
  • 0
tngrlkrz

Did you try Bob's descendancy chart, not the ancestor chart?  It should show both spouses, and his children by those marriages. 

Ron

Share this post


Link to post
  • 0
Scott Kampen

Hello Ron and Jay, thank you both for your responses.

Ron - I tried Bob's reports from multiple angles, but couldn't see any secondary spouses/families.

Jay - I did not run the secondary step.  Arrrgghh, guess I missed that part.  Will have to figure out how to do that now.

Thanks again for both responses.  I will work on figuring out the secondary process.

Scott

 

 

Share this post


Link to post
  • 0
Scott Kampen

Thanks again.  I was able to find the secondary operations, but even after performing them the data remained the same at the website.  Therefore, I looked at the GEDCOM file in an editor and sure enough the particular family I am trying to correct isn't linked properly.  They do show properly when I run reports within my RootsMagic software, so I have a feeling that my GEDCOM is corrupt.  I will run a new GEDCOM and try to import that again.

I appreciate your help.

Scott

 

Share this post


Link to post
  • 0
Scott Kampen

Just a quick update to this thread.  Thank you all for the responses and the guidance to helping me resolve the issue.  It was a combination of a bad GEDCOM file and the fact that I had not performed the secondary operations to link/trace family lines.  My databases is now updated and reporting multiple marriages as I would expect to see them.

My site is not 100% ready for public viewing, but here is the link to what I have available so far in a sub-directory:

 

New site with TNG http://www.iamaleaf.com/genealogy/index.php

Old site which was made by hand editing html pages until my fingers bled http://www.iamaleaf.com

 

Thanks again,

Scott Kampen

 

 

Share this post


Link to post
  • 0
tngrlkrz

New site link produces error: An error has occurred in the TNG software. This could be due to a setup issue, an incomplete upgrade or a program bug. ............

Ron

 

OK now...looks good.

Share this post


Link to post
  • 0
theKiwi
On 11/10/2017 at 5:56 PM, Scott Kampen said:

 and the fact that I had not performed the secondary operations to link/trace family lines. 

Track Lines doesn't actually alter the database and affect the display of multiple marriages etc - all it does is go through the database and identify the people who have children by putting a mark beside their name on the person display page.

If you don't run this, the database will function as normal - you just won't get the indication of which kids have kids.

Roger

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×