Jump to content
TNG Community
Paul Barrett

RESOLVED: GEDCOM issue

Recommended Posts

Paul Barrett    0
Paul Barrett

I took a GEDCOM export from Family Tree Maker to update my tree with latest updates made there.

The new file seems to have an adverse effect on TNG's records.

In the Image below, (A) is my father's TNG record before the import

(B) is part of the same record after the GEDCOM import.  Gender has been replaced by a symbol (1), and another of these symbols has been inserted at (2). At (3) the data is wrapping instead of displaying a long a single row.

(C) is the GEDCOM import settings I used. (D) is what happens when i try to load an ancestor tree (all names missing, no photos, and a permanent 'Loading' spinner.  if I choose a Family display (E) that is OK.  

Restoring the files from backup fixes the problem

If I import the GEDCOM in to a new tree instead of merging to the existing, the new tree shows the same issues.

I can replicate this from the first step of creating a brand new GEDCOM file.  Of course, the problem may lie with the FTM app that generated the GEDCOM but I wondered if anybody had even seen anything like this and had any suggestions please?

All images required by the import were copied from FTM to the photos folder of TNG before the import.

2017-04-18_08-02-49.png

Share this post


Link to post
Share on other sites
Paul Barrett    0
Paul Barrett

UPDATE:

I thought that the GEDCOM file from FTM might be corrupted or contain some odd formatting.

To test this I tried importing it into other apps. I used the free version of Legacy 8.  I also set up a brand new tree in Ancestry and imported it there.

Both worked fine.

 

So now I have to think about the settings I used to overlay the new GEDCOM file on the existing TNG data?  These settings look OK to me.  Did I do something wrong?

2017-04-18_17-22-38.jpg

Share this post


Link to post
Share on other sites
theKiwi    0
theKiwi

If you are importing a GEDCOM file that contains your entire database then you have to use the "All Current Data" option for Replace.

Roger

Share this post


Link to post
Share on other sites
Paul Barrett    0
Paul Barrett

Thanks Roger

I tried that.  Same issue.

In email dialogue with Darrin it seemed that FTM's GEDCOM  was malformed.  I was all set to speak to FTM when I decided to import the FTM GEDCOM into Legacy 9, check it out there (it was good) and generate a new GEDCOM from Legacy, in the hope it would filter out the anomalies.  

Unfortunately it didn't.  I get the exact same problem in TNG with a GEDCOM from two unrelated apps.  I will try some more.

 

Paul

Share this post


Link to post
Share on other sites
Paul Barrett    0
Paul Barrett

RESOLVED!!!! :-D

I tried some more apps.  They all performed the same way.

Conclusion reached with Darrin is that we can't easily know the root cause.  It could be that there is something buried in my Ancestry.com tree that is embedding extra hard returns in the data.  But as my modest little tree (1,444 people) generates a GEDCOM with 72,000 rows, the needle and haystack principle applies..

The final resolution? Darrin tweaked the TNG import routine to strip out extra hard returns and BINGO!

I had to endure the user Interfaces of 6 different apps during the troubleshooting.  My goodness there are some shockers out there. I fell more and more in love with TNG with every app I visited. No names mentioned but there was one whose users had praised the new UI brought in about 18 months ago.  It looks like something from the days of Windows 3.1, for those of you who have long memories.

From looking at their GEDCOM import/export routines, I also learned that the words GEDCOM and STANDARD should rarely be used in the same sentence.  

TNG and Ancestry are the only ones to have a minimalist import and export routine and are so much better for it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×