Jump to content
TNG Community
raisondetre

Image not showing 100% in viewer

Recommended Posts

raisondetre

I am wondering why a reasonably sized image is not shown fully at 100% within the frame of the viewer. It is close but usually the full height of the image is not seen at first view. This problem applies to all images, all sizes. I have set up for media as 'Image max height = 600' and Image max width = 800'. Please see clip below. 

The image will show at 100% when hovered over in the photo list. It also shows the full image in slideshow. And I know it can be viewed in full at 75% when in the viewer. But I would like to see the full image there - all edges of frames, etc. - without adjustment.

I suspect that this is a template issue (Template 14) . . . perhaps in genstyle.css or templatestyle.css. Can I enlarge the viewer - especially height? Are the viewer dimensions specified in .css files? If so, how do I adjust? Is there a way to choose 'always view at 75%" in the viewer as default? Or is this a computer screen limitation (using 17" laptop)? Other ideas? Thanks!

 

Image issue delete.JPG

 

 

Share this post


Link to post
Share on other sites
Merv

Hi,

Have you tried another browser or another device to view them on?

Share this post


Link to post
Share on other sites
tngrlkrz

The size must be reduced with the controls available in the viewer if it was imported with a larger size than the screen. By viewer, are you referring to what showmedia.php (in the url) displays? Are you using the 'pan' mode? Then you can scroll up and down to view the entire image, or zoom in or out, or set a % percentage of the size you imported to TNG .  A couple clicks and most images can fit on your screen.

In the photolist or 'browsemedia' , you see the entire image because it is reduced in size for a preview, not a full image size view.  Again, depends on the size image you imported or loaded into TNG media folder.

Ron

 

Share this post


Link to post
Share on other sites
raisondetre

Merv . . . I am using Google Chrome but tried it in Microsoft Edge . . . same issue there.

Ron . . . I know I can use the controls to get around within the viewer. They work fine and I can see everything when I use them. I would just like to be about to see 100% without doing that. These are not large images. Before uploading I have resized all to be under a total of 200 KB - most well under that - with the longer side (length or width) max 600 px. 

As for:  "In the photolist or 'browsemedia' , you see the entire image because it is reduced in size for a preview, not a full image size view" . . . aha! I didn't realize that. 

There seems to be a lot of 'real estate' in the viewer window border (light green) area - see all that area (marked with red curvy line) below the white viewing area. So that's why it seemed I could change the inner dimensions - those of the white window itself - to accommodate the full image. If I could just 'pull' the bottom of the white frame down some then the bottom edge of the image would show. Perhaps this really isn't even necessary. I am editing etc. before uploading. It's just curious though. I thought I might be able to change some internal setting.   Can you both see your full images - all edges, i.e. frame - without using the viewer controls? Thanks, Margie

Image issue delete2.JPG

Share this post


Link to post
Share on other sites
Merv

The only way I can reproduce your issue on my site  is to set the zoom to 125%. Can you give us a screenshot of the controls along the top?

1 hour ago, raisondetre said:

Merv . . . I am using Google Chrome but tried it in Microsoft Edge . . . same issue there.

Have you got a link (and a temp access if required) for your site? I can try on another device.

Share this post


Link to post
Share on other sites
tngrlkrz

Yes, when viewing, the frame or image edges are always visible, though scrolling may be required, but there is no cutoff, even with template14.

Agree with Merv,  we need to be able to see first hand with different devices what you're seeing.  Their should be space below the photo with styling the same as around the other sides, I would think.  That's the way the unmodified viewer works for me on my laptop. The showmedia.php viewer control of percentage of size defaults to 100% when you land on the screen. If the pixel resolution of the original image doesn't fit on your screen, it will be partially visible, and you should see a scroll bar on the right to be able to see or pan the entire image.  If you want it to always fit in the viewing area, there is control to fit to width or fit to height, but , there is not a function to fit to screen (height and width), similar to the way the browsemedia preview does.  At least this has been my experience.

The slide show reduces the image to 'fit' the slide show box, essentially the same as the browsemedia preview image.

Did you make any modifications at all to TNG?  Your colors are not the default of template14.   Do you have a right scroll bar? If you've made changes, have you tried template 14 unmodified? Or switch (as a test) to another unmodified template?

Ron

Share this post


Link to post
Share on other sites
raisondetre

OK I'll open up temporarily to both of you. And yes . . . I had tech help altering template 14  to have a central area on the home page with the surname cloud below. I like how it is coming together - very happy with the overall. I am going slowly as I set my 'conventions' as you will see. The fact that the template was adjusted in css and even the index.php in order the fit the central 'feature area' is why I thought this would be a design adjustment. 

Sooo, although I would like to see the image 100%, if it means messing with the overall, it won't be worth it. Anyway, take a look and see what you think. Merv, i think you have been here before

WAIT . . . ! I went ahead and set you both up with temp guest access and edit media rights and went in to see what you would see and I now cannot replicate the issue!! So I logged out and went back in as administrator and now (NOW?) the images are within the window. I truly do not know what happened here?! I'll be back if the problem reappears. Thanks for putting your heads on this . . . good grief . . . 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×