Jump to content
TNG Community
  • 0
Hava

His side her side on template 13

Question

Hava

i just started with TNG and imported my gedcom file. on template 13 I try to connect his side to an existing person. i put person id I1 and family tree Porat (I have only 1 family tree) but without success.

it should be easy. what is wrong?

Share this post


Link to post

24 answers to this question

Recommended Posts

  • 0
Merv

Welcome to TNG, Have you got the address to your site?

Share this post


Link to post
  • 0
Merv

ok...

The only thing I can think of is to ensure that the tree ID has been entered and not the tree name. The default ID for the first tree is tree1. If you have relabeled the tree ID as Porat or porat then ensure that the ID ihas been entered identically to that of the tree as it is case sensitive, and that there are no spaces before, during or after the entry.

Share this post


Link to post
  • 0
Merv

Hi Hava, I don't have any experience as far as a computer install is concerned but I imagine it would function the same as an online install. Are you able to bring up the pedigree and ancestor charts for them through their individual pages? Are all the other links working okay??

6 hours ago, Hava said:

please the attached file

The document you attached has come up blank at my end?

 

Share this post


Link to post
  • 0
Hava

Hi Merv, yes I can see the pedigree. If I reach the person using the search I can see the family. My problem is how to make the first link from"his side" to the person in order to see the whole tree, as I know it exist. 

Share this post


Link to post
  • 0
Merv

Hi,

So the chart is displaying but not how you would like it to?

Share this post


Link to post
  • 0
Hava

The chart seems to be ok. My problem is how to link the chart to "his side her side" on the welcome page of chart 13 . I just want that when I'll click on "his side" I'll get the member with the id I1, the chart will appear with it (hopefully)

 

 

Share this post


Link to post
  • 0
Merv

Hi, So what happens when you click the links?

  • Nothing happens at all
  • You get an error message
  • You get the chart but for the wrong person
  • You get the chart for the correct person but not the one you would like
  • Something else

 

 

Share this post


Link to post
  • 0
Hava
26 minutes ago, Merv said:

Hi, So what happens when you click the links?

  • Nothing happens at all
  • You get an error message
  • You get the chart but for the wrong person
  • You get the chart for the correct person but not the one you would like
  • Something else

 

 

I get empty chart as if i do not have members

Share this post


Link to post
  • 0
Merv

Does the link in resemble something similar to the one that Kare posted?

 

For some reason the individuals aren't linking to each other in the chart. Something else you could try if you haven't already is to (re)run the "track lines" gedcom  secondary process again.

Admin>Import/Export>Secondary Processes>Track Lines

Share this post


Link to post
  • 0
Hava
1 hour ago, Kare said:

I this what you need? .. here with TNG installed at a laptop in the wamp/www/TNG folder
 http://localhost/tng/verticalchart.php?personID=I1&tree=tree1&generations=

maybe. I thought that thru the administration menu I can link to the member without going to the code. it suppose to be easy. I can see the members and the pedigree but not from the link of "his side"

see both attached files

New Microsoft Word Document.docx

Capture.PNG

Share this post


Link to post
  • 0
Merv

Hi Hava,

The word document shows all the template fields as empty. What have you actually put in those fields?

Have you got a screen shot of that?

 

Share this post


Link to post
  • 0
Hava

Hi Merv,

thank you for your patience. 

i made now 3 screen shots. 1- the information on the admine screen.  2- is the result i get after i click on "his side"

and 3- the information that i get when i search person id I1.

as you see i have the information but can't link it to "his side" on the welcome screen.

Capture.JPG

Capture1.JPG

Capture2.JPG

Share this post


Link to post
  • 0
Merv

Hi Hava, The chart in screen shot 3 is the family chart and not the pedigree/ancestors chart. Do the ancestor charts display ok on your computer program?

Share this post


Link to post
  • 0
Hava
17 hours ago, Merv said:

Hi Hava,

The word document shows all the template fields as empty. What have you actually put in those fields?

Have you got a screen shot of that?

 

Hi Merv,

enclose ancestors screen shot.

How are you? did you feel the earthquake?

ancestors.jpg

Share this post


Link to post
  • 0
Merv

OK, that is the chart that is supposed to display when you click on the His/Her Side tab. This proves that the chart works, so it is more than likely a link problem.

Aew you able to hover over the His or Her side tab and copy the link address? (right click and the copy the link/url) and paste it back here. Also the address where the chart is displaying ok.

The key may be the difference between these 2 links.

Didn't feel a thing here although I live at the top of the North Island and the quake was at the top of the South Island maybe 1300km away?... https://www.google.co.nz/maps/dir/Hanmer+Springs/Taipa/@-38.7679647,169.8116693,6z/data=!3m1!4b1!4m14!4m13!1m5!1m1!1s0x6d3063796f545947:0x500ef86847973f0!2m2!1d172.8288246!2d-42.5262427!1m5!1m1!1s0x6d09829d02b2e85b:0x500ef6143a2b790!2m2!1d173.4665818!2d-34.9961839!3e0

Share this post


Link to post
  • 0
Hava

http://localhost/pedigree.php?personID=I1&tree=Porat  this is from his side

http://localhost/pedigree.php?personID=I1&tree=T1  this is from ancestors.

i put T1 on his side and now it works ok. but i don't understand. i do have only 1 tree (Porat) what is T1. i search for trees in the application and found only 1 tree.

can you explain this? will it not make troubles with my future use? 

I thought that you live in Taupo which is also on the north island but closer to Christchurch.

tree.JPG

Share this post


Link to post
  • 0
Merv

Hi Hava,

I have no idea why T1 is required. Maybe it's because the system doesn't like the capital P in the ID?... but the instructions don't stipulate lowercase letters only. Maybe others here may have a better idea or something that Darrin needs to be aware of?

I also don't know if there will be any further repercussions of this quirk in the future

The other thing is that the chart displayed is stipulated by the settings in the Admin>Setup>Charts>Pedigree settings.

Share this post


Link to post
  • 0
Hava

Hi Merv,

Thank you very much for your help and patience.

Have a good day

 

Share this post


Link to post
  • 0
Ken Roy
5 hours ago, Hava said:

http://localhost/pedigree.php?personID=I1&tree=Porat  this is from his side

http://localhost/pedigree.php?personID=I1&tree=T1  this is from ancestors.

i put T1 on his side and now it works ok. but i don't understand. i do have only 1 tree (Porat) what is T1. i search for trees in the application and found only 1 tree.

can you explain this? will it not make troubles with my future use? 

I thought that you live in Taupo which is also on the north island but closer to Christchurch.

tree.JPG

Porat is your Tree Name.  The link requires the Tree ID.  To find it you need to display the Tree record.  T1 is evidently your treeID.

Share this post


Link to post
  • 0
Merv
8 hours ago, Ken Roy said:

Porat is your Tree Name.  The link requires the Tree ID.  To find it you need to display the Tree record.  T1 is evidently your treeID.

13 hours ago, Hava said:

can you explain this? will it not make troubles with my future use? 

Hi,

I thought we covered this at the beginning... but a screenshot of the tree setup would prove it either way... Admin>Trees

If the Tree ID is T1 then there shouldn't be any future detrimental issues.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×