Jump to content
TNG Community
John S. Nielsen

Invalid characters in report csv file

Recommended Posts

John S. Nielsen

This topic concerns csv report with invalid danish characters.

When I want to see a report as a csv file from the report page, I get strange characters in stead of the danish Æ,Ø,Å and æ,ø,å. And it's only when I use export to a csv-file function. 

It looks like this: Fødselsdato" - it should be "Fødselsdato"

Any ideas to solve this?

Share this post

Link to post
Share on other sites

What are you using to open the file with? I just tried your Report 1 and downloaded the file to my Macintosh, and opened it with BBEdit - it opened as expected.


Screen Shot 2016-09-29 at 3.53.54 PM.png

Share this post

Link to post
Share on other sites
John S. Nielsen

Hello Roger,

Thanks for your respond.

I'm using MS Excel 2016 (Windows 10) as I want to analyze the data in the file. If I just opens the file as a .txt file in NotePad++ I get exactly the same as you do - with the right characters. But the problem arises when you want to go the step further and take data into Excel.

I found a solution - and I hope other users may find it usefull:

The standard settings for the "datatype" in Excel (Import Guide) has to be changed from "Windows (ANSI)" to "65001: Unicode(UTF-8)". You do that in Excel from the "DATA" menu and choosing "From text" (in Danish "Fra tekst"). Please see attached pictures for documentation.


In Windows 10 you may set the standard app to Excel if you want to open a ".csv" file. BUT in this case Windows only handles "semicolon separated" files, which don't help in this TNG specific case . Even if it did so I'm not sure it would resolve the data type issue.




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now