Jump to content
TNG Community
Hardy

Setting Permissions TNG On Synology NAS With DSM 5.0+

Recommended Posts

jrvd

I could not get passed the permissions setting in the TNG11.1 setup through the readme.html file.

I followed Hardy's instructions in the first posting, step 3. In File Station I changed the rights for every file but every time I clicked on "set permissions" in the readme.html file I got the same error in TNG that permissions could not be set so I did not proceed.
After that I tried Total Commander, Putty, WinSCP to set the TNG permissions but the permissions error in TNG kept popping up.

So I only focused on getting rid of this permissions error before taking the next step in TNG installation and I guess this is my mistake.

On Monday Hardy mentioned that

On ‎13‎-‎2‎-‎2017 at 9:56 PM, Hardy said:

This is why my instructions say go to step '6. Establish Database connection'. It means you should skip all before it.

I did not understand the instructions this way and to be honest, I still cannot find this part that says to skip all steps and go to step 6 ;-).
But it is exactly what I did now. Despite the error in the readme.html setup that permissions could not be set, I simply moved to step 6 and entered the database settings and finished the installation. I imported my Gedcom and so far, it looks ok. Under diagnostics, I see only green lights so everything appears to be correct.

I hope it is all working now and thank you all for the help (and patience)
 

Share this post


Link to post
Share on other sites
Hardy

Steve1200, great tip on using the diagnostics.

jrvd, Glad you got it sorted. I think you're right, my instructions could have been clearer. To clarify for the next reader:

  • Follow Steps 1 and 2 in Darrin's Express Installation.
  • Do not execute, Steps 3 & 4 in Darrin's Express Installation, they will not work. Replace with Steps 3 and 4 in the original post.
  • Execute Step 5 to change the language if necessary.
  • Continue with Step 6 onwards in Darrin's Express Installation.
  • After completing the installation, run diagnostics to check file permissions are correct.

 

  • Repeat Steps 3 and/or 4 in my original post for files/folders which still show a problem in diagnostics.

 

Share this post


Link to post
Share on other sites
ned_worcs

Synology DSM 6+  Maria Data Base 10

You will need to change the default values on the database configuration (or via config.php if you upgrade) to:

Port = 3307

Domain Socket =  /run/mysqld/mysqld10.sock

as they are different to MDB5 which uses the default values.

HTH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×