Jump to content
TNG Community
tngrlkrz

Relationship Display Mod ---Function Nest Overflow

Recommended Posts

tngrlkrz

Only on Wamp Server TNG 11.0.1, occasionally getting this overflow error with the J.Robison's Relationship Display Mod.  Appears to happen when a nesting level is reached, while calculating relationships.  Is there a setting somewhere for this, or a Wamp server limitation?  Works fine on Live and Test websites.  

Is it possible a Windows memory constraint reached? The last entry in memory column is 1,500,000+.

 

2016-06-22_7-42-31.jpg

Ron

TNG 11.0.1   http://www.kmtrees.com wampserver 2.5,legacy 7.5,  family historian 6.2.2, win 10 pro

Share this post


Link to post
Share on other sites
Ken Roy

Ron,

 

It is more likely that the error message is being suppressed on your hosting service.

Share this post


Link to post
Share on other sites
tngrlkrz

OK, thanks, didn't realize errors are sometimes suppressed on the web host.  What seems different though, it that when the error occurs, the circular  'loading symbol keeps revolving, like it is active.   In both cases the end of the page displays properly.

Ron

TNG 11.0.1   http://www.kmtrees.com wampserver 2.5,legacy 7.5,  family historian 6.2.2, win 10 pro

 

Share this post


Link to post
Share on other sites
Dan Cote

Hi,

I had the same error with TNG 11.1.2 on my local setup:

  • Windows 10 Professional 64 bit x64 
  • Wampserver 3.1.0 64 bit x64 
  • Apache 2.4.27 
  • PHP 5.6.31/7.0.23/7.1.9
  • MySQL 5.7.19

This is an Intel Core i5 (Dell Laptop) with 16 GB RAM and a 300 GB SDD. This a fresh installation of Windows 10 without Office or any additional software except recommended Microsoft VC++ packages VC2008, 2010, 2012, 2013, 2015, 2017 for Wampserver.

Error message:
"Fatal error: Maximum function nesting level of '256' reached, aborting! in C:\wamp64\www\tng\tngconnect.php on line 157"

In Find Relationship page, I used these parameters:

  • Maximum relationships to show: 10
  • Show relationships involving a spouse: Yes
  • Maximum generations to check: 40

The error message is misleading (tngconnect.php) as this is a problem with the PHP XDEBUG Extension (php_xdebug-2.5.5-5.6-vc11-x86_64.dll). The problem may be fixed in php.ini located in the Apache directory:

[Wamp Directory]\bin\apache\[Apache Directory]\bin\php.ini

Look for section [xdebug], and comment this line (with a ;):
;zend_extension ="c:/wamp64/bin/php/php5.6.31/zend_ext/php_xdebug-2.5.5-5.6-vc11-x86_64.dll"
This will prevent the XDEBUG Extension to load.

If you use XDEBUG Extension, you may want increase the nesting level by adding this line (use a number higher than 256):
xdebug.max_nesting_level=500

Here is my complete [xdebug] section:

Citation

[xdebug]

; Comment the line below to disable xdebug
;zend_extension ="c:/wamp64/bin/php/php5.6.31/zend_ext/php_xdebug-2.5.5-5.6-vc11-x86_64.dll"
xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir ="c:/wamp64/tmp"
xdebug.show_local_vars=0
; This line is added to set the max nesting level
xdebug.max_nesting_level=500

Dan

Share this post


Link to post
Share on other sites
Ken Roy

Dan,

You might want to publish this valuable solution in the TNG Wiki troubleshooting category so that it can be more easily found in the future.

I can help with the wiki formatting syntax if needed. 

Thanks,

Share this post


Link to post
Share on other sites
tngrlkrz

Dan,

Thanks for posting.

My OP was 16 months ago, and I just tested and no longer get that error, with the exact same settings on the Find Relationship page, on TNG 11.1.2.   I seem to have resolved that problem sometime since then.  Also on Windows 10, but with Wamp server 2.5, 32 bit.  My xdebug section looks the same, but nothing appears commented out and nesting level was already at 500.  Perhaps I found a solution from googling about but  forgot to post here; just not sure at this point until I review my archives.

; XDEBUG Extension

zend_extension = "R:/Wamp/bin/php/php5.5.12/zend_ext/php_xdebug-2.2.5-5.5-vc11.dll"
;
[xdebug]
xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir = "R:/Wamp/tmp"
xdebug.show_local_vars=0
xdebug.max_nesting_level = 500

Ron

 

 

Share this post


Link to post
Share on other sites
Ken Roy

Ron,

It looks like you increased the nesting level for the XDebug Extension.  Since this is not an obvious solution to the problem to the casual WampServer user, I wanted Dan to document it on the TNG Wiki in the Troubleshooting Category.

By the way, what the heck is an OP?  I have no clue so I had to Google it to find the answer.

Share this post


Link to post
Share on other sites
Dan Cote
Il y a 6 heures , Ken Roy said:

You might want to publish this valuable solution in the TNG Wiki troubleshooting category so that it can be more easily found in the future.

I can help with the wiki formatting syntax if needed. 

Hello,

I will add this solution to the wiki later today.

Dan

Share this post


Link to post
Share on other sites
tngrlkrz
7 hours ago, Ken Roy said:

Ron,

It looks like you increased the nesting level for the XDebug Extension.  Since this is not an obvious solution to the problem to the casual WampServer user, I wanted Dan to document it on the TNG Wiki in the Troubleshooting Category.

By the way, what the heck is an OP?  I have no clue so I had to Google it to find the answer.

I've seen OP used as original poster on other forums; sorry if my usage may have been unclear.  Yes,  I mentioned the nesting level was increased, I just couldn't remember where I got the solution. I believe is was googling about back then and found an answer like this:

https://piwik.org/faq/troubleshooting/faq_20014/

Ron

Share this post


Link to post
Share on other sites
Dan Cote

Hi,

I have published this solution on the TNG Wiki:

WampServer Fatal error - Maximum function nesting level

Please feel free to update it. English is not my native language and I tried to keep it easy for anyone having the same failure.

Dan

 

 

 

Share this post


Link to post
Share on other sites
Ken Roy

Un grand merci Dan,

Moi aussi ma première langue n'est pas l'anglais. 

(For those who are not bilingual in French and English)

Thank you very much Dan,

English is also not my first language.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×