Jump to content
TNG Community
Sign in to follow this  
mugwumpr

Can't create MySQL tables

Recommended Posts

mugwumpr

Hi ho,

I'm trying to install TNG 5.12 on my server (Apache2, PHP5, MySQL5, Windows box), and it does just fine until the table creation step, then it just sits there saying, "Please wait, attempting to process..." and creating no tables.

The id and password were verified in the previous step, and are also the ones I'm using for other PHP/MySQL programs, so I know they work.

Has anyone encountered this? Any suggestions on how to get it working?

Share this post


Link to post
Share on other sites
rdmorss

Does your database exist on the mysql server? If not, use a mysql database utility such as phpmyadmin to create an empty mysql database and give it a name (which you'll using in your db settings in TNG admin.

You could also try running the TNG diagnostics: Admin|Setup and Config|Run Diagnostics and see what it says.

Share this post


Link to post
Share on other sites
mugwumpr

Yup, database exists, user has privileges, and diagnostic says everything is ticketty-boo.

Edit: Don't ask me why, but it's suddenly decided to co-operate. *shrug* Go fig. Thanks for your help!

:)

Share this post


Link to post
Share on other sites
Chris

I am having the identical problem. I've never had difficulty setting up MySql Tables before. How long did it take for yours to just work? Did you have to keep retrying on the same table creation page?

Yup, database exists, user has privileges, and diagnostic says everything is ticketty-boo.

Edit: Don't ask me why, but it's suddenly decided to co-operate. *shrug* Go fig. Thanks for your help!

:)

Share this post


Link to post
Share on other sites
mugwumpr

How long did it take for yours to just work? Did you have to keep retrying on the same table creation page?

I just tried it a couple of times after posting, then gave up until the next day, and suddenly everything turned green and worked perfectly.

If it's any help, I had a bubble-bath and a good night's sleep..... can't have been anything on the server, 'cause I didn't touch any of that at all between the last failed attempt and the successful attempt.

Did you try deleting all the tables and starting from scratch? That's worked for me in setting up other scripts.

Good luck!

:-)

Share this post


Link to post
Share on other sites
waltreams

Had you made significant changes to any of the component programs (apache, mysql, etc). I was fighting the same thing on my LAMP server the other day until a brownout from a storm caused a restart. Magically, everything worked. Maybe it's the order in which the programs restart?

Funny thing, when I couldn't write to the database, I was also getting blanks for "server" and "browser" in the diagnostics screen - green lights, but blank responses...

Walt

Share this post


Link to post
Share on other sites
Chris

I just tried it a couple of times after posting, then gave up until the next day, and suddenly everything turned green and worked perfectly.

:-)

No dice yet.. I wish I could just get the MySql table structure and I would set it up directly in the database.

Share this post


Link to post
Share on other sites
Chris

No dice yet.. I wish I could just get the MySql table structure and I would set it up directly in the database.

It continues to hang. I get a small notice on the lower left corner of explorer that there is an "Error on page." When I click on that notice I get this information:

Line: 86

Char: 2

Error: 'null' is null or not an object

Code: 0

URL: {gives me the URL where I am calling the readme.html file from}

Does anybody have a suggestion. I have tried with both IE and Foxfire, at home and at work. I haven't tried a bubble bath yet.

Share this post


Link to post
Share on other sites
Chris

It continues to hang. I get a small notice on the lower left corner of explorer that there is an "Error on page." When I click on that notice I get this information:

Line: 86

Char: 2

Error: 'null' is null or not an object

Code: 0

URL: {gives me the URL where I am calling the readme.html file from}

Does anybody have a suggestion. I have tried with both IE and Foxfire, at home and at work. I haven't tried a bubble bath yet.

Finally it worked.

However, never got it to work from the "readme.html" file. Could never figure out what the error was. I tried building all the tables manually in MySQL using the sql commands from the tnginstall.php file and PHPMyAdmin. Then started the program admin menu. Noticed I was getting some database errors. Was looking over all the menu selections and found one that said "Setup and Configuration." I chose that and found a button that said "Create Tables." What the heck, figured if I'd made any errors in building the tables manually this might fixed them. Clicked on the button... VOILA! Worked like a champ.

I am up and running now. I went back and read the readme.html file and didn't see any info on building the tables this way. If anyone else has this problem, suggest you can skip right to the admin program after you have created the database and build your tables from there instead of the readme.html file.

Whew... I was afraid I was going to have to take a bath before next Saturday...

Share this post


Link to post
Share on other sites
mugwumpr

Finally it worked.

.

.

.

Whew... I was afraid I was going to have to take a bath before next Saturday...

:shock:

Whoa, close call, Chris!! So glad to hear that it finally worked for you.

:grin:

Share this post


Link to post
Share on other sites
PalmBeachG

I am having the identical problem. I've never had difficulty setting up MySql Tables before. How long did it take for yours to just work? Did you have to keep retrying on the same table creation page?

Well now mine doesn't work either - can't get the tables to work. I started a 100% clean install and have never had problems with setting up a database or tables before. I get all green lights, and a test of my database on my server says all is fine. But the error message I keep getting is that the tables are not communicating with my database. This is the first time I have ever tried a different root folder, for example genealogy; that is the only thing I have done differently.

Share this post


Link to post
Share on other sites
Chris

Well now mine doesn't work either - can't get the tables to work. I started a 100% clean install and have never had problems with setting up a database or tables before. I get all green lights, and a test of my database on my server says all is fine. But the error message I keep getting is that the tables are not communicating with my database. This is the first time I have ever tried a different root folder, for example genealogy; that is the only thing I have done differently.

Do you mean you established a folder in your root folder called genealogy? Like "www.mydomain.com/genealogy/"

Share this post


Link to post
Share on other sites
Scotty

Well now mine doesn't work either - can't get the tables to work. I started a 100% clean install and have never had problems with setting up a database or tables before. I get all green lights, and a test of my database on my server says all is fine. But the error message I keep getting is that the tables are not communicating with my database. This is the first time I have ever tried a different root folder, for example genealogy; that is the only thing I have done differently.

I have mine under a folder off my root and it looks like this, if this is what you are trying to do

Root Path = /home/[main domain-name]/www/www/genealogy/

Genealogy URL = http://[main domain-name]/genealogy

Scott

Share this post


Link to post
Share on other sites
Chris

I have mine under a folder off my root and it looks like this, if this is what you are trying to do

Root Path = /home/[main domain-name]/www/www/genealogy/

Genealogy URL = http://[main domain-name]/genealogy

Scott

Assuming you have established your genealogy folder as Scott suggests (that is how mine is also) and that you can get to your TNG Admin page (from your post above I assume you have) - Have you tried selecting the "Setup & Configuration" menu item? Under general settings you should see the database specifics: Host, Name, Username, and Password. (Probably localhost, genealogy, root, and your password). You should also see the tables all listed there. If you don't see the table names and your database info is correct, go back to the top "Setup & Configuration" menu and try clicking on the "Create Tables" button. (If you already have tables you may want to "drop" them from MySql before you attempt to create them again.) This procedure worked for me.

Share this post


Link to post
Share on other sites
PalmBeachG

Do you mean you established a folder in your root folder called genealogy? Like "www.mydomain.com/genealogy/"

Yes, that is what I did; it is the only thing I did different from before. Last time I installed TNG I did not use a folder called genealogy, I just uploaded the files to my www.mydomain.com. This time I did www.domain.com/genealogy because I wanted to make my own index page that I can link to www.mydomain.com/genealogy/index.php. Does this make a difference?

Assuming you have established your genealogy folder as Scott suggests (that is how mine is also) and that you can get to your TNG Admin page (from your post above I assume you have) - Have you tried selecting the "Setup & Configuration" menu item? Under general settings you should see the database specifics: Host, Name, Username, and Password. (Probably localhost, genealogy, root, and your password). You should also see the tables all listed there. If you don't see the table names and your database info is correct, go back to the top "Setup & Configuration" menu and try clicking on the "Create Tables" button. (If you already have tables you may want to "drop" them from MySql before you attempt to create them again.) This procedure worked for me.

Well it is kinda late right now, so will look at it tomorrow, but yes, I did get to my TNG Admin page and I did select Setup & Configuration. I know my username, password and database name is correct because I have done it 3 times before with different websites and it always worked. I saw the tables listed there.

After hours of trying, I finally deleted my SQL database on my server and started over fresh, making a new database with a new user, and giving user permissions, and a new password. Still didn't work.

Haven't tried since; I think I will try again tomorrow.

Share this post


Link to post
Share on other sites
PalmBeachG

Assuming you have established your genealogy folder as Scott suggests (that is how mine is also) and that you can get to your TNG Admin page (from your post above I assume you have) - Have you tried selecting the "Setup & Configuration" menu item? Under general settings you should see the database specifics: Host, Name, Username, and Password. (Probably localhost, genealogy, root, and your password). You should also see the tables all listed there. If you don't see the table names and your database info is correct, go back to the top "Setup & Configuration" menu and try clicking on the "Create Tables" button. (If you already have tables you may want to "drop" them from MySql before you attempt to create them again.) This procedure worked for me.

I am at a loss; ready to give up.

When I press on make tables, I get a message that it is not communicating with my database.

I have made them before through the control panel on my hosting service with no trouble. There is a button on my control panel to test the database and it comes out working fine. Also, I definitely know the database Name, the database User Name and the password. All permissions have been assiged.

On my TNG administration page, when I run diagnostics, I get all green lights.

Maybe one of these are wrong under general settings:

rootpath: /home/myservername/public_html/houghamfamilytree/genealogy/

Homepage: index.php

Genealogy URL: http://www.houghamfamilytree.com/genealogy/index.php

are these correct formats?

Share this post


Link to post
Share on other sites
Jpaprocki

Are you doing this on your own home computer setup like a server or via a hosrint company? Also what version of Apache and MySql are you using? There has been some issues with Apache 2.* and MySQL with a version less than 4.1. This also holds true for PHP 5 and MySQL <4.1.

6. If you are running MySQL 4.1 with anything less than PHP 5, the difference in password authentication schemes could cause a problem. Check here for instructions on how to fix this: http://dev.mysql.com/doc/mysql/en/Old_client.html

I couldn't get the tables to create via the readme so dont use it. Use the TNG Admin to create them. If your with a hosting provider that recently upgraded to php 5 then you may want to check this: From Readme

please make sure that your php.ini file (part of PHP, not TNG) contains the following settings:

file_uploads = On

error_reporting = E_ALL & ~E_NOTICE

If you have PHP 5, please make sure you use extension=php_mysql.dll and copy lib-mysql.dll to where PHP can find it. Also set the following:

register_long_arrays = On

If you can find a line in php.ini referencing the value LimitRequestBody then comment it out or delete it, as this will prevent you from uploading files larger than the size indicated on that line (sometimes this value is located in the php.conf file, so look for it there if you don't find it in php.ini).

You may also wish to increase the value for upload_max_filesize if you have a large GEDCOM file. It could also be advantageous to set output_buffering to "On".

If your PHP installation is on a Windows machine, you may have to change the session.save_path variable to point to your Windows temporary folder (i.e., C:\Temp). If you make changes to your php.ini file, you must restart your PHP service before the changes take effect

The part I bout in bold is important. If this is not done, PHP will have a hard time communicating with the database.

Good Luck to you. I know how it goes when something works one day and doens't the next :?

Share this post


Link to post
Share on other sites
mugwumpr

I think I've found what my problem was on a 2nd installation. I had the MySQL Administrator program running.... it connects on exactly the same port that TNG needs to create the tables (3306).

Double-check to make sure that you don't have any administrative programs running for MySQL or anything else that might be blocking port 3306. Not sure about phpMyAdmin......

Looks like it wasn't the bubblebath after all.

;)

Share this post


Link to post
Share on other sites
Rasmus

Line: 86

Char: 2

Error: 'null' is null or not an object

Code: 0

URL: {gives me the URL where I am calling the readme.html file from}

Does anybody have a suggestion. I have tried with both IE and Foxfire, at home and at work. I haven't tried a bubble bath yet.

I'm having the same thing going on as Chris, and I have no idea how to solve the probelm.

The TNG files has been uploaded to the webpage through the Explorer ftp client, but when I get to Step 4: Database Settings, I can't get any further, because I can't contact with my webhost's MySQL database.

What I now is this: my webhost has phpMyAdmin 2.6.4-pl4 with MySQL 4.1.14-standard (I don't have any privileges) and PHP4.

My question is: should I install PHP, MySQL and Apache, or is there an easier way to solve my problems?

Just so you know: I'm a total newing with making webpages. :oops:

Rasmus

P.S. Thanks for letting me in the forum. :-D

Share this post


Link to post
Share on other sites
Scotty

Welcome to TNG from another newbie...

The TNG files has been uploaded to the webpage through the Explorer ftp client, but when I get to Step 4: Database Settings, I can't get any further, because I can't contact with my webhost's MySQL database.

What I now is this: my webhost has phpMyAdmin 2.6.4-pl4 with MySQL 4.1.14-standard (I don't have any privileges) and PHP4.

If you don't have any priviledges I'm curious if you can create a database? What is the name of your host?

My question is: should I install PHP, MySQL and Apache, or is there an easier way to solve my problems?

Highly doubtfull, you will be allowed to install any of these on a remote server. If you were talking about on your computer, sure.

Just so you know: I'm a total newing with making webpages. :oops:

Rasmus

P.S. Thanks for letting me in the forum. :-D

Hey two weeks ago I could'nt even spell TNG. Ask Darrin, he'll point out some of my really brain dead questions I had for him.... Maybe you really should'nt he's busy. :oops:

Scotty

Share this post


Link to post
Share on other sites
Rasmus

If you don't have any priviledges I'm curious if you can create a database? What is the name of your host?

Oh, my host have already created a database, and provided me the name of it. I just don't have any priviledges. I can only kill it.

My host's name is www.unoeuro.com

Share this post


Link to post
Share on other sites
Scotty

Oh, my host have already created a database, and provided me the name of it. I just don't have any priviledges. I can only kill it.

My host's name is www.unoeuro.com

Even tho, I can't read Danish. I did notice there is a KontrolPanel. Have you tried to log into it?

Usually the username and password for the Control Panel is the same for MySQL. Once logged in look for a link for the MySQL database and see what is there. Hopefully you will see the name of the database. And since you are there see if there is a "System Info" link. Hopefully it will show installed software and the paths to get to them.

And lastly take a look at the "support" tab on the main page. It has items on SQL and PHP.

I just tried the tab "bestilling" and I noticed they have different levels of service. And what appears to be a limit of some sort.

Hopefully from those pages you can find the information you need.

Scotty

Share this post


Link to post
Share on other sites
Rasmus

Hey Scotty.

I do know the name of my MySQL database. The problem is that the script don't want to connect with the database at all. Then I asked Unoeuro: are you blocking the access to the MySQL database through a script, and they said no.

Then I asked Unoeuro for support with the script problem, but they refused to give script support.

I have no idea what I do now... :sad:

Share this post


Link to post
Share on other sites
Scotty

Hey Scotty.

I do know the name of my MySQL database. The problem is that the script don't want to connect with the database at all. Then I asked Unoeuro: are you blocking the access to the MySQL database through a script, and they said no.

Then I asked Unoeuro for support with the script problem, but they refused to give script support.

I have no idea what I do now... :sad:

What is the name of your website where I would find the TNG files?

I want to take a look at something.

Scotty

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×