Jump to content
TNG Community
Sign in to follow this  
JThorin

WP-TNG Kloosterman method: TNG pages unformatted

Recommended Posts

JThorin

Hello,

I'm working on a WP-TNG site (http://www.thorinfamily.net) using a possibly untested theme (Sensible by modern themes.net). I feel like I am very close to getting everything to work right, but I am encountering just the slightest of difficulties. From my limited perspective and background, I would not assume that the issues I am facing are related to the theme. But I don't know much about these things.

The issue is that the TNG pages appear totally unformatted, as if there is no CSS customization going on at all (I've tried moving the CSS files from TNG template 13 into the tng/css folder to no avail). Otherwise, the header and footer from the WP theme appear just fine (menu functionality and all). This can be confirmed by navigating to "Surname Index" under "What to See" (some of the links are not yet established and that's my fault; things [WP pages, etc.] are still under construction).

At first the TNG pages were blank, but removing "wp();" from the WPTNG-topmenu.php fixed that as mentioned on other posts. But what might be causing the completely unformatted TNG pages?

Thank you,

JThorin

P.S. I realize that clicking on the links for the TNG pages might bring you to a login.php screen, but the issue is apparent there too.

Share this post


Link to post
Share on other sites
theKiwi

Something is wrong with your paths - the source code shows

 

<link href="css/genstyle.css?v=10.1.1" rel="stylesheet" type="text/css" />
<link href="css/templatestyle.css?v=10.1.1" rel="stylesheet" type="text/css" />
 

which would be correct for TNG, but those .css files are showing up empty when the links are clicked.

 

Roger

Share this post


Link to post
Share on other sites
JThorin

Could it be because the TNG folder is inside the WP (root) folder per the Kloosterman method directions? I.E. the path should be "<link href="tng/css/genstyle.css..."?

JThorin

Share this post


Link to post
Share on other sites
JThorin

Just noticed this in the errors for the source (I'm using Safari's source viewer):

[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (genstyle.css, line 0) http://www.thorinfamily.net/genealogy/css/genstyle.css?v=10.1.1
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (templatestyle.css, line 0) http://www.thorinfamily.net/genealogy/css/templatestyle.css?v=10.1.1
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (mytngstyle.css, line 0) http://www.thorinfamily.net/genealogy/css/mytngstyle.css?v=10.1.1

So I'd say the directory is correct. I checked the files in my FTP client just in case but they are populated documents.

JThorin 

Share this post


Link to post
Share on other sites
JThorin

So you know, though I found those errors, I have no clue why they're appearing :? . Permission is set to 644 (rw-r--r--) on the files. My host is Simply Hosting (the one recommended by TNG). Does any of this information help trigger any possible solutions out there?

JThorin

Share this post


Link to post
Share on other sites
klooster

You have to use the absolute URL in your meta.php

So use :

http://www.thorinfamily.net/genealogy/css/mytngstyle.css

 

and:

Set in TNG Admin Setup >> Configuration >> Template Settings Enable Template Selection to NO and click SAVE.

Share this post


Link to post
Share on other sites
JThorin

Thank you for chiming in, klooster. I tried the following code but the server is returning the same error with the addition of css file path specified in this code:

<?php

    global $cms;

?>

<link href="<?php echo $cms['tngpath']; ?>

http://www.thorinfamily.net/genealogy/css/mytngstyle.css" rel="stylesheet" type="text/css" /

I don't know much about php though, so I wonder if something here is amiss.

JThorin 

Share this post


Link to post
Share on other sites
klooster

The code line ” global $cms; ” is optional. I do not need it in my theme, Try it without the ” global $cms; ” 

And check your root path in the TNG admin "path and Folders "section"!

Share this post


Link to post
Share on other sites
JThorin

I tried eliminating the "global $cms" portion of the code to no avail. The root path is "/home/X/public_html/genealogy/" (where "X" = host name). That appears to be correct.

Assuming the path is correct, I cannot figure out why I'm getting a 404 error for the css file. I will try a fresh install of TNG and see if that does anything.

JThorin

Share this post


Link to post
Share on other sites
JThorin

Now I'm officially stumped. Used Cyberduck FTP client to remove the old ../genealogy/ directory, which seems to have worked fine, and tried to throw in the freshly unzipped contents of TNG into a new folder called "genealogy." According to the FTP client, everything looks fine, but any URL from the newly updated directory that I enter in my browser returns a 404 page from the WP theme (including the initial "readme" HTML file). 

Did I miss a crucial step here? I haven't uploaded the custom meta, topmenu, and footer files yet because I simply wanted to see if the new TNG install would display the css formatting. But if I can't get to the directory then that's a whole different issue.

Am I missing something?

JThorin

Share this post


Link to post
Share on other sites
JThorin

RESOLVED!

Thanks for your help and patience everyone (especially Klooster)!

Of all things, I had to set the permissions of the new "../genealogy/" TNG install to 755 from 700. Once I did that, I was able to access the readme.html and begin setup. However, when that was done, the formatting was still lacking. This got me thinking, "Maybe the permissions need to be changed for the '../genealogy/css/' folder too." So I changed it from 700 to 755 and VOILÀ! It's now looking good. 

A little bit of tweaking and I'll be home free!

JThorin

Share this post


Link to post
Share on other sites
klooster

Glad to be of help, nice to know you got it working!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×